configure.in
changeset 74 777c60922f56
parent 70 4d33d6915f49
child 77 444ef677160f
--- a/configure.in	Wed Jan 21 22:13:28 2004 +0000
+++ b/configure.in	Wed Jan 21 22:24:40 2004 +0000
@@ -2,7 +2,7 @@
 
 AM_CONFIG_HEADER(config.h)
 
-AM_INIT_AUTOMAKE(loudmouth, 0.14.1.99)
+AM_INIT_AUTOMAKE(loudmouth, 0.15)
 
 AM_MAINTAINER_MODE
 
@@ -150,27 +150,27 @@
 dnl  --------------
 dnl | mono setup |--------------------------------------------
 dnl  --------------
-AC_ARG_ENABLE(mono, [  --enable-mono        build mono bindings [default=auto]], enable_mono="$enableval", enable_mono=auto)
-                                                                                
-if test "x$enable_mono" != "xno"; then
-    PKG_CHECK_MODULES(,gtk-sharp,have_mono=yes,have_mono=no)
+dnl AC_ARG_ENABLE(mono, [  --enable-mono        build mono bindings [default=auto]], enable_mono="$enableval", enable_mono=auto)
                                                                                 
-    if test "x$have_mono" = "xyes"; then
-        AC_PATH_PROG(GAPI_FIXUP, gapi-fixup, no)
-        AC_PATH_PROG(GAPI_CODEGEN, gapi-codegen, no)
-        AC_PATH_PROG(MCS, mcs, no)
-        AC_PATH_PROG(MONO, mono, no)
-    fi
-else
-    have_mono=no
-fi
+dnl if test "x$enable_mono" != "xno"; then
+dnl     PKG_CHECK_MODULES(,gtk-sharp,have_mono=yes,have_mono=no)
+dnl                                                                             dnl     
+dnl     if test "x$have_mono" = "xyes"; then
+dnl         AC_PATH_PROG(GAPI_FIXUP, gapi-fixup, no)
+dnl         AC_PATH_PROG(GAPI_CODEGEN, gapi-codegen, no)
+dnl         AC_PATH_PROG(MCS, mcs, no)
+dnl         AC_PATH_PROG(MONO, mono, no)
+dnl     fi
+dnl else
+dnl     have_mono=no
+dnl fi
                                                                                 
-if test "x$enable_mono" = "xyes"; then
-    AC_MSG_CHECKING(for mono environment)
-    if test "x$have_mono" = "xno"; then
-        AC_MSG_ERROR([not found])
-    fi
-fi
+dnl if test "x$enable_mono" = "xyes"; then
+dnl     AC_MSG_CHECKING(for mono environment)
+dnl     if test "x$have_mono" = "xno"; then
+dnl         AC_MSG_ERROR([not found])
+dnl     fi
+dnl fi
                                                                                 
 AM_CONDITIONAL(HAVE_MONO, test x$have_mono = xyes)
 
@@ -178,12 +178,13 @@
 Makefile
 docs/Makefile
 docs/reference/Makefile
-mono/Makefile
-mono/loudmouth/Makefile
 loudmouth/Makefile
 loudmouth-1.0.pc
 loudmouth.spec])
 
+dnl mono/Makefile
+dnl mono/loudmouth/Makefile
+
 dnl ==========================================================================
 echo "
 
@@ -196,16 +197,16 @@
 
 	"
 		    
-if test x$enable_mono = xyes ; then
-echo \
-"        mcs:                     ${MCS}
-         mcsflags:                ${MCSFLAGS}
-"
-else
-echo \
-"        mcs:                     (not enabled)
-"
-fi
+dnl if test x$enable_mono = xyes ; then
+dnl echo \
+dnl "        mcs:                     ${MCS}
+dnl          mcsflags:                ${MCSFLAGS}
+dnl "
+dnl else
+dnl echo \
+dnl "        mcs:                     (not enabled)
+dnl "
+dnl fi
 
 echo \