configure.in
changeset 70 4d33d6915f49
parent 65 e6871fda6fc9
child 74 777c60922f56
--- a/configure.in	Fri Jan 16 00:09:09 2004 +0000
+++ b/configure.in	Wed Jan 21 18:02:57 2004 +0000
@@ -140,17 +140,83 @@
 	echo "Debugging enabled"
 fi
 
-
-
 AC_SUBST(LOUDMOUTH_CFLAGS)
 AC_SUBST(LOUDMOUTH_LIBS)
 
-#CFLAGS="$CFLAGS $WARN_CFLAGS"
+dnl +--------------------------------------+
+dnl | Check if we shoudl build C# bindings |-------------------
+dnl +--------------------------------------+
+
+dnl  --------------
+dnl | mono setup |--------------------------------------------
+dnl  --------------
+AC_ARG_ENABLE(mono, [  --enable-mono        build mono bindings [default=auto]], enable_mono="$enableval", enable_mono=auto)
+                                                                                
+if test "x$enable_mono" != "xno"; then
+    PKG_CHECK_MODULES(,gtk-sharp,have_mono=yes,have_mono=no)
+                                                                                
+    if test "x$have_mono" = "xyes"; then
+        AC_PATH_PROG(GAPI_FIXUP, gapi-fixup, no)
+        AC_PATH_PROG(GAPI_CODEGEN, gapi-codegen, no)
+        AC_PATH_PROG(MCS, mcs, no)
+        AC_PATH_PROG(MONO, mono, no)
+    fi
+else
+    have_mono=no
+fi
+                                                                                
+if test "x$enable_mono" = "xyes"; then
+    AC_MSG_CHECKING(for mono environment)
+    if test "x$have_mono" = "xno"; then
+        AC_MSG_ERROR([not found])
+    fi
+fi
+                                                                                
+AM_CONDITIONAL(HAVE_MONO, test x$have_mono = xyes)
 
 AC_OUTPUT([
 Makefile
 docs/Makefile
 docs/reference/Makefile
+mono/Makefile
+mono/loudmouth/Makefile
 loudmouth/Makefile
 loudmouth-1.0.pc
 loudmouth.spec])
+
+dnl ==========================================================================
+echo "
+
+                    Loudmouth $VERSION
+	=========================================
+
+        prefix:                   ${prefix}
+        compiler:                 ${CC}
+        cflags:                   ${CFLAGS}
+
+	"
+		    
+if test x$enable_mono = xyes ; then
+echo \
+"        mcs:                     ${MCS}
+         mcsflags:                ${MCSFLAGS}
+"
+else
+echo \
+"        mcs:                     (not enabled)
+"
+fi
+
+echo \
+
+echo \
+"        Enable SSL               ${ac_ssl}
+"
+echo \
+"        Enable Debug:            ${enable_debug}
+"
+
+echo \
+"        Now type 'make' to build Loudmouth
+"
+