Fri, 01 May 2015 15:28:47 -0700 histedit: fix serializing of None backupfile stable
Durham Goode <durham@fb.com> [Fri, 01 May 2015 15:28:47 -0700] rev 24958
histedit: fix serializing of None backupfile If the histedit backupfile was None (like if evolve is enabled) it would get serialized as 'None' into the state file. Later if the histedit was aborted and the top most commit was unreachable (ex: if it was obsolete or stripped), histedit would try to unbundle the backupfile and try to read .hg/None. This fixes it to not serialize None. Since it only happens with evolve, I'm not sure how to add test coverage here.
Thu, 07 May 2015 14:19:20 -0500 merge with stable
Matt Mackall <mpm@selenic.com> [Thu, 07 May 2015 14:19:20 -0500] rev 24957
merge with stable
Tue, 05 May 2015 08:40:59 -0700 treemanifest: set requires at repo creation time, ignore config after
Martin von Zweigbergk <martinvonz@google.com> [Tue, 05 May 2015 08:40:59 -0700] rev 24956
treemanifest: set requires at repo creation time, ignore config after The very next changeset will start writing one revlog per directory when tree manifests are enabled. That is backwards incompatible, so it requires .hg/requires to be updated. Just like with generaldelta, we want to update .hg/requires only when the repo is created. Updating ..hg/requires is bad for repos on shared disk. Instead, those who do want to upgrade a repo to using treemanifest (or manifestv2, etc) can run hg clone --config experimental.treemanifest repo clone which will create a new repo with the requirement set. Unlike the case of e.g. generaldelta, it will not rewrite the changesets, since tree manifests hash differently.
Tue, 21 Apr 2015 09:29:59 -0700 remove: use ctx.hasdir(f) instead of 'f in ctx.dirs()'
Martin von Zweigbergk <martinvonz@google.com> [Tue, 21 Apr 2015 09:29:59 -0700] rev 24955
remove: use ctx.hasdir(f) instead of 'f in ctx.dirs()' This speeds up 'hg remove python/README' on the Firefox repo from 2.479s to 0.664s with lazily loaded treemanifests (which is not yet in core) and has no measurable effect on flat manifests.
Mon, 04 May 2015 23:04:12 -0400 largefiles: drop os.path.join() in subrepo archive override
Matt Harbison <matt_harbison@yahoo.com> [Mon, 04 May 2015 23:04:12 -0400] rev 24954
largefiles: drop os.path.join() in subrepo archive override This is related to 41cd8171e58f, but not required for that to function correctly because 'prefix' always ends with '/', so os.path.join(prefix, _path) simply concatenates the strings. Take the opportunity to drop the os.path usage, and avoid confusion by using the same pattern as the overridden subrepo method.
Tue, 05 May 2015 20:52:38 -0400 archive: drop the leading '.' path component from the prefix (issue4634)
Matt Harbison <matt_harbison@yahoo.com> [Tue, 05 May 2015 20:52:38 -0400] rev 24953
archive: drop the leading '.' path component from the prefix (issue4634) Unix utilities like tar will happily prefix the files it packs with './', but annoyingly, Windows Explorer will not show these packed files when it opens the archive. Since there doesn't seem to be a point in including './' in the path names, just drop it. The default 'hg archive' prefix is the basename of the archive, so specifying '.' allows for that default to be disabled completely.
Thu, 07 May 2015 07:46:39 +0900 hgweb: bring back infinite scroll in shortlog of paper style stable
Yuya Nishihara <yuya@tcha.org> [Thu, 07 May 2015 07:46:39 +0900] rev 24952
hgweb: bring back infinite scroll in shortlog of paper style Since fdf7794be41d, column headers are wrapped by <thead> element, so the first and only <tbody> contains changelog data. I got the following error without this patch: Uncaught TypeError: Cannot read property 'lastElementChild' of null scrollHandler @ mercurial.js:375
Thu, 07 May 2015 13:47:45 -0500 merge with stable
Matt Mackall <mpm@selenic.com> [Thu, 07 May 2015 13:47:45 -0500] rev 24951
merge with stable
Wed, 06 May 2015 09:52:10 -0700 extensions: clear aftercallbacks after execution (issue4646) stable
Gregory Szorc <gregory.szorc@gmail.com> [Wed, 06 May 2015 09:52:10 -0700] rev 24950
extensions: clear aftercallbacks after execution (issue4646) It was reported that enabling pager without color could cause a hang. Inserting print statements revealed that the callbacks in extensions._aftercallbacks were being invoked twice. extensions.loadall can be called multiple times. If entries in extensions._aftercallbacks linger between calls, this could result in double execution of the callbacks. This can lead to unwanted behavior. The reproduce steps in the bug seem to only occur when the output of a command is less than the size of the current screen. This is not something that can easily be tested. I verified the test case works with this patch and that pager and color interaction continues to work. Since we have no existing automated tests for pager, this sadly appears to be the best testing I can do.
Mon, 04 May 2015 10:17:34 +0900 templater: strictly parse leading backslashes of '{' (issue4569) (BC) stable
Yuya Nishihara <yuya@tcha.org> [Mon, 04 May 2015 10:17:34 +0900] rev 24949
templater: strictly parse leading backslashes of '{' (issue4569) (BC) Because double backslashes are processed as a string escape sequence, '\\{' should start the template syntax. On the other hand, r'' disables any sort of \-escapes, so r'\{' can go either way, never start the template syntax or always start it. I simply chose the latter, which means r'\{' is the same as '\\{'.
Mon, 04 May 2015 09:54:01 +0900 templater: do not process \-escapes at parsestring() (issue4290) stable
Yuya Nishihara <yuya@tcha.org> [Mon, 04 May 2015 09:54:01 +0900] rev 24948
templater: do not process \-escapes at parsestring() (issue4290) This patch brings back pre-2.8.1 behavior. The result of parsestring() is stored in templater's cache, t.cache, and then it is parsed as a template string by compiletemplate(). So t.cache should keep an unparsed string no matter if it is sourced from config value. Otherwise backslashes would be processed twice. The test vector is borrowed from 64b4f0cd7336.
Tue, 14 Apr 2015 13:17:33 -0700 bookmarks: rename bookmarkcurrent to activebookmark (API)
Ryan McElroy <rmcelroy@fb.com> [Tue, 14 Apr 2015 13:17:33 -0700] rev 24947
bookmarks: rename bookmarkcurrent to activebookmark (API) Today, the terms 'active' and 'current' are interchangeably used throughout the codebase in reference to the active bookmark (the bookmark that will be updated with the next commit). This leads to confusion among developers and users. This patch is part of a series to standardize the usage to 'active' throughout the mercurial codebase and user interface.
Mon, 13 Apr 2015 23:03:13 -0700 bookmarks: rename readcurrent to readactive (API)
Ryan McElroy <rmcelroy@fb.com> [Mon, 13 Apr 2015 23:03:13 -0700] rev 24946
bookmarks: rename readcurrent to readactive (API) Today, the terms 'active' and 'current' are interchangeably used throughout the codebase in reference to the active bookmark (the bookmark that will be updated with the next commit). This leads to confusion among developers and users. This patch is part of a series to standardize the usage to 'active' throughout the mercurial codebase and user interface.
Mon, 13 Apr 2015 22:27:01 -0700 bookmarks: rename setcurrent to activate (API)
Ryan McElroy <rmcelroy@fb.com> [Mon, 13 Apr 2015 22:27:01 -0700] rev 24945
bookmarks: rename setcurrent to activate (API) Today, the terms 'active' and 'current' are interchangeably used throughout the codebase in reference to the active bookmark (the bookmark that will be updated with the next commit). This leads to confusion among developers and users. This patch is part of a series to standardize the usage to 'active' throughout the mercurial codebase and user interface.
Mon, 13 Apr 2015 21:53:37 -0700 bookmarks: rename unsetcurrent to deactivate (API)
Ryan McElroy <rmcelroy@fb.com> [Mon, 13 Apr 2015 21:53:37 -0700] rev 24944
bookmarks: rename unsetcurrent to deactivate (API) Today, the terms 'active' and 'current' are interchangeably used throughout the codebase in reference to the active bookmark (the bookmark that will be updated with the next commit). This leads to confusion among developers and users. This patch is part of a series to standardize the usage to 'active' throughout the mercurial codebase and user interface.
Wed, 06 May 2015 17:15:38 +0200 subrepo: correctly handle git subdirectory status change
Mathias De Maré <mathias.demare@gmail.com> [Wed, 06 May 2015 17:15:38 +0200] rev 24943
subrepo: correctly handle git subdirectory status change 'git diff-index' by default does not recurse into subdirectories when changes are found. As a result, the directory is shown as changed, rather than the files in this directory. Adding '-r' results in recursing until the blobs themselves are checked.
Wed, 06 May 2015 16:56:28 -0500 merge with stable
Matt Mackall <mpm@selenic.com> [Wed, 06 May 2015 16:56:28 -0500] rev 24942
merge with stable
Sun, 12 Apr 2015 15:36:10 -0400 setup: hide octal literals inside strings so they're portable (issue4554)
Augie Fackler <augie@google.com> [Sun, 12 Apr 2015 15:36:10 -0400] rev 24941
setup: hide octal literals inside strings so they're portable (issue4554)
Wed, 26 Mar 2014 15:55:50 -0700 revset: avoid returning duplicates when returning ancestors
Pierre-Yves David <pierre-yves.david@fb.com> [Wed, 26 Mar 2014 15:55:50 -0700] rev 24940
revset: avoid returning duplicates when returning ancestors Before this patch, _revancestors were giving false result when a revision was duplicated in the input. Duplicated entry are rare but may happen when using the `%lx` notation internally. This series has no visible impact on the performance of the function according to benchmark.
Wed, 26 Mar 2014 16:21:30 -0700 revset: use an iterator instead of a dequeue in ancestors()
Pierre-Yves David <pierre-yves.david@fb.com> [Wed, 26 Mar 2014 16:21:30 -0700] rev 24939
revset: use an iterator instead of a dequeue in ancestors() The dequeue was actually just used to be able to pop value one at a time. Building the dequeue means we are reading all the input value at once at the beginning of the evaluation. This defeat the lazyness of revset. We replace the deque with iterator usage for the sake of simplicity and lazyness. This provide massive speedup to get the first result if the input set is big max(::all()) before) wall 0.001917 comb 0.000000 user 0.000000 sys 0.000000 (best of 1115) after) wall 0.000107 comb 0.000000 user 0.000000 sys 0.000000 (best of 22222)
Wed, 06 May 2015 11:29:09 -0700 revset: return early when revs is empty
Martin von Zweigbergk <martinvonz@google.com> [Wed, 06 May 2015 11:29:09 -0700] rev 24938
revset: return early when revs is empty By introducing an early return in _revancestors() when revs is empty, we make it so inputrev is never None, which simplifies the subsequent code.
Wed, 26 Mar 2014 16:14:30 -0700 revset: rename 'revsnode' to 'inputrev' in ancestors
Pierre-Yves David <pierre-yves.david@fb.com> [Wed, 26 Mar 2014 16:14:30 -0700] rev 24937
revset: rename 'revsnode' to 'inputrev' in ancestors We usually use 'node' for variable containing 20 bytes hash. There is nothing nodish in this variable, so we rename it to "inputrev" as it old the next entry of the iteration.
Mon, 04 May 2015 12:36:48 -0700 revset: make generatorset.__nonzero__ lazy
Pierre-Yves David <pierre-yves.david@fb.com> [Mon, 04 May 2015 12:36:48 -0700] rev 24936
revset: make generatorset.__nonzero__ lazy The 'for r in self:' call could trigger full consumption of the generator while we only need a single value. We also fast path if a single value got already computed. See inline comment for more details. This provide massive speedup for lazy operation using boolean testing. max(::tip) e5b507efb36e) wall 0.055609 comb 0.060000 user 0.060000 sys 0.000000 (best of 100) after change) wall 0.000109 comb 0.000000 user 0.000000 sys 0.000000 (best of 19146)
Tue, 05 May 2015 15:33:01 -0700 tests: test that we can convert to manifestv2 with clone
Drew Gottlieb <drgott@google.com> [Tue, 05 May 2015 15:33:01 -0700] rev 24935
tests: test that we can convert to manifestv2 with clone This just adds a test to ensure that we can convert a manifestv1 repo to a manifestv2 repo (for future commits only) by means of a local clone.
Mon, 13 Apr 2015 18:11:47 -0400 requires: move requires file writing func from localrepo to scmutil
Drew Gottlieb <drgott@google.com> [Mon, 13 Apr 2015 18:11:47 -0400] rev 24934
requires: move requires file writing func from localrepo to scmutil The logic to read a requires file resides in scmutil, so it's only logical that the logic to write the file should be there too. And now I've typed logic too many times it no longer looks like a word. Logically.
Tue, 05 May 2015 11:15:17 -0700 histedit: fix test-histedit-edit on vfat stable
Durham Goode <durham@fb.com> [Tue, 05 May 2015 11:15:17 -0700] rev 24933
histedit: fix test-histedit-edit on vfat test-histedit-edit was broken because it relied on the HGEDITOR script being executable. Instead, lets just execute 'sh' and pass it the script to run. This seems to be the pattern followed in other tests.
Sun, 03 May 2015 12:28:15 -0400 revset: don't error out if tokens parse as existing symbols
Jordi Gutiérrez Hermoso <jordigh@octave.org> [Sun, 03 May 2015 12:28:15 -0400] rev 24932
revset: don't error out if tokens parse as existing symbols It makes perfect sense for tokens to parse as existing revset symbols (revset functions), and doesn't break anything, since parsing symbols as functions works correctly in the presence of parens. For example, if "only" is a bookmark, this used to error out, hg log -r "only(only, @)" which shouldn't, as the inner "only" is unambiguously not a function. So we just remove the symbolset function and replace its calling site with the stringset function. For the tests, we confirm that "date" and "only" are both parsed as revision names both inside revset expressions (e.g. an expression containing ::) and inside old-style revision expressions (e.g. those containing the name of the revision alone).
Tue, 05 May 2015 12:33:26 -0500 merge with stable
Matt Mackall <mpm@selenic.com> [Tue, 05 May 2015 12:33:26 -0500] rev 24931
merge with stable
Sun, 26 Apr 2015 13:43:01 -0400 test-command-template: minor clarification in comment
Jordi Gutiérrez Hermoso <jordigh@octave.org> [Sun, 26 Apr 2015 13:43:01 -0400] rev 24930
test-command-template: minor clarification in comment
Tue, 28 Apr 2015 15:29:15 -0400 test-command-template: test the phase template more precisely
Jordi Gutiérrez Hermoso <jordigh@octave.org> [Tue, 28 Apr 2015 15:29:15 -0400] rev 24929
test-command-template: test the phase template more precisely The current test that greps for "phase:" only checks that the word "phase" is in the output, but does not test that nothing else gets added by this template. This improves these tests by showing a unified
(0) -10000 -3000 -1000 -300 -100 -50 -30 +30 +50 +100 +300 +1000 +3000 +10000 tip