setup.py
changeset 6009 f077815932ce
parent 5623 f22708f50213
child 6239 39cfcef4f463
--- a/setup.py	Sun Feb 03 19:29:05 2008 -0600
+++ b/setup.py	Sun Feb 03 19:29:05 2008 -0600
@@ -40,11 +40,6 @@
 except ImportError:
     pass
 
-if os.name in ['nt']:
-    extra['scripts'] = ['hg']
-else:
-    extra['scripts'] = ['hg', 'hgmerge']
-
 # specify version string, otherwise 'hg identify' will be used:
 version = ''
 
@@ -77,6 +72,7 @@
       url='http://selenic.com/mercurial',
       description='Scalable distributed SCM',
       license='GNU GPL',
+      scripts=['hg'],
       packages=['mercurial', 'mercurial.hgweb', 'hgext', 'hgext.convert'],
       ext_modules=ext_modules,
       data_files=[(os.path.join('mercurial', root),