setup.py
changeset 6239 39cfcef4f463
parent 6009 f077815932ce
child 6241 a718e66836e8
--- a/setup.py	Wed Mar 12 22:20:10 2008 +0100
+++ b/setup.py	Wed Mar 12 15:30:11 2008 -0700
@@ -59,6 +59,14 @@
     Extension('mercurial.diffhelpers', ['mercurial/diffhelpers.c'])
     ]
 
+packages = ['mercurial', 'mercurial.hgweb', 'hgext', 'hgext.convert']
+
+if sys.platform == 'linux2' and os.uname()[2] > '2.6':
+    # the inotify extension is only usable with Linux 2.6 kernels
+    ext_modules.append(Extension('hgext.inotify.linux._inotify',
+                                 ['hgext/inotify/linux/_inotify.c']))
+    packages.extend(['hgext.inotify', 'hgext.inotify.linux'])
+
 try:
     import posix
     ext_modules.append(Extension('mercurial.osutil', ['mercurial/osutil.c']))
@@ -73,7 +81,7 @@
       description='Scalable distributed SCM',
       license='GNU GPL',
       scripts=['hg'],
-      packages=['mercurial', 'mercurial.hgweb', 'hgext', 'hgext.convert'],
+      packages=packages,
       ext_modules=ext_modules,
       data_files=[(os.path.join('mercurial', root),
                    [os.path.join(root, file_) for file_ in files])