setup.py
changeset 33103 db8531c45953
parent 32890 20fc5d39d0c1
child 33110 6fdc1518983e
--- a/setup.py	Tue Jun 27 00:23:32 2017 +0530
+++ b/setup.py	Sun Jun 25 08:36:51 2017 +0530
@@ -182,7 +182,7 @@
 
 if os.path.isdir('.hg'):
     cmd = [sys.executable, 'hg', 'log', '-r', '.', '--template', '{tags}\n']
-    numerictags = [t for t in runhg(cmd, env).split() if t[0].isdigit()]
+    numerictags = [t for t in runhg(cmd, env).split() if t[0:1].isdigit()]
     hgid = runhg([sys.executable, 'hg', 'id', '-i'], env).strip()
     if numerictags: # tag(s) found
         version = numerictags[-1]