setup.py
changeset 44202 a7f8160cc4e4
parent 44115 e1b8b4e4f496
child 44240 15eb90965a00
--- a/setup.py	Tue Jan 28 22:35:08 2020 -0500
+++ b/setup.py	Tue Jan 28 22:27:30 2020 -0500
@@ -323,7 +323,7 @@
     # gives precedence to hg.exe in the current directory, so fall back to the
     # python invocation of local hg, where pythonXY.dll can always be found.
     check_cmd = ['log', '-r.', '-Ttest']
-    if os.name != 'nt':
+    if os.name != 'nt' or not os.path.exists("hg.exe"):
         try:
             retcode, out, err = runcmd(hgcmd + check_cmd, hgenv)
         except EnvironmentError: