setup.py
changeset 32655 7dab4c0cdb41
parent 32647 331dcf199039
child 32725 6c4b58422974
--- a/setup.py	Sat Jun 03 16:33:28 2017 -0400
+++ b/setup.py	Sat Jun 03 14:05:52 2017 +0900
@@ -371,6 +371,9 @@
                                  'Mercurial but weren\'t found in %s' % h)
 
     def run(self):
+        basepath = os.path.join(self.build_lib, 'mercurial')
+        self.mkpath(basepath)
+
         if self.distribution.pure:
             modulepolicy = 'py'
         elif self.build_lib == '.':
@@ -378,7 +381,7 @@
             modulepolicy = 'allow'
         else:
             modulepolicy = 'c'
-        with open("mercurial/__modulepolicy__.py", "w") as f:
+        with open(os.path.join(basepath, '__modulepolicy__.py'), "w") as f:
             f.write('# this file is autogenerated by setup.py\n')
             f.write('modulepolicy = b"%s"\n' % modulepolicy)