setup.py
changeset 32725 6c4b58422974
parent 32655 7dab4c0cdb41
child 32782 9a4adc76c88a
--- a/setup.py	Tue Jun 06 10:09:48 2017 -0400
+++ b/setup.py	Tue Jun 06 11:02:30 2017 -0400
@@ -469,6 +469,17 @@
         return os.path.join(self.build_temp, dir, 'hg.exe')
 
 class hginstall(install):
+
+    user_options = install.user_options + [
+        ('old-and-unmanageable', None,
+         'noop, present for eggless setuptools compat'),
+        ('single-version-externally-managed', None,
+         'noop, present for eggless setuptools compat'),
+    ]
+
+    # Also helps setuptools not be sad while we refuse to create eggs.
+    single_version_externally_managed = True
+
     def get_sub_commands(self):
         # Screen out egg related commands to prevent egg generation.  But allow
         # mercurial.egg-info generation, since that is part of modern