setup.py
changeset 31289 718a57e95a89
parent 30907 75149f84eac7
child 31308 62939e0148f1
--- a/setup.py	Thu Mar 09 19:41:40 2017 -0800
+++ b/setup.py	Thu Mar 09 19:59:52 2017 -0800
@@ -63,7 +63,10 @@
 import shutil
 import tempfile
 from distutils import log
-if 'FORCE_SETUPTOOLS' in os.environ:
+# We have issues with setuptools on some platforms and builders. Until
+# those are resolved, setuptools is opt-in except for platforms where
+# we don't have issues.
+if os.name == 'nt' or 'FORCE_SETUPTOOLS' in os.environ:
     from setuptools import setup
 else:
     from distutils.core import setup