setup.py
changeset 48850 656196c1d442
parent 48842 649ff7f86f96
child 48946 642e31cb55f0
--- a/setup.py	Sat Feb 19 22:14:41 2022 -0700
+++ b/setup.py	Wed Mar 02 18:42:00 2022 -0800
@@ -5,17 +5,11 @@
 # 'python setup.py --help' for more options
 import os
 
-# Mercurial will never work on Python 3 before 3.5 due to a lack
-# of % formatting on bytestrings, and can't work on 3.6.0 or 3.6.1
-# due to a bug in % formatting in bytestrings.
-# We cannot support Python 3.5.0, 3.5.1, 3.5.2 because of bug in
-# codecs.escape_encode() where it raises SystemError on empty bytestring
-# bug link: https://bugs.python.org/issue25270
+# Mercurial can't work on 3.6.0 or 3.6.1 due to a bug in % formatting
+# in bytestrings.
 supportedpy = ','.join(
     [
-        '>=3.5.3',
-        '!=3.6.0',
-        '!=3.6.1',
+        '>=3.6.2',
     ]
 )