setup.py
changeset 10123 52c98c6d7297
parent 10028 873d9b9a7bac
parent 10120 fb890a546d44
child 10126 78b8acae2088
--- a/setup.py	Mon Dec 21 23:01:46 2009 +0200
+++ b/setup.py	Wed Dec 23 18:40:57 2009 +0100
@@ -104,9 +104,11 @@
     # If root is executing setup.py, but the repository is owned by
     # another user (as in "sudo python setup.py install") we will get
     # trust warnings since the .hg/hgrc file is untrusted. That is
-    # fine, we don't want to load it anyway.
+    # fine, we don't want to load it anyway.  Python may warn about
+    # a missing __init__.py in mercurial/locale, we also ignore that.
     err = [e for e in err.splitlines()
-           if not e.startswith('Not trusting file')]
+           if not e.startswith('Not trusting file') \
+              and not e.startswith('warning: Not importing')]
     if err:
         return ''
     return out