setup.py
branchstable
changeset 10120 fb890a546d44
parent 9856 ed362d41d1f6
child 10123 52c98c6d7297
child 10124 08384d8777a4
--- a/setup.py	Wed Dec 23 12:04:17 2009 +0000
+++ b/setup.py	Sat Dec 05 14:18:31 2009 -0600
@@ -104,9 +104,11 @@
     # If root is executing setup.py, but the repository is owned by
     # another user (as in "sudo python setup.py install") we will get
     # trust warnings since the .hg/hgrc file is untrusted. That is
-    # fine, we don't want to load it anyway.
+    # fine, we don't want to load it anyway.  Python may warn about
+    # a missing __init__.py in mercurial/locale, we also ignore that.
     err = [e for e in err.splitlines()
-           if not e.startswith('Not trusting file')]
+           if not e.startswith('Not trusting file') \
+              and not e.startswith('warning: Not importing')]
     if err:
         return ''
     return out