tests/mockblackbox.py
author Pierre-Yves David <pierre-yves.david@octobus.net>
Wed, 06 Mar 2024 01:53:52 +0100
changeset 51526 a03fa40afd01
parent 48875 6000f5b25c9b
permissions -rw-r--r--
filteredhash: rename the filteredhash function The new name is less ambiguous, as we are about to introduce an alternative function it seems like a good idea to have clearer name to distinct the two.

from mercurial.utils import procutil

# XXX: we should probably offer a devel option to do this in blackbox directly
def getuser():
    return b'bob'


def getpid():
    return 5000


# mock the date and user apis so the output is always the same
def uisetup(ui):
    procutil.getuser = getuser
    procutil.getpid = getpid