mcabber/configure.ac
changeset 1454 6b98dc22946d
parent 1448 844410b9b4cc
child 1456 5e99e802656c
--- a/mcabber/configure.ac	Wed Apr 02 22:31:23 2008 +0200
+++ b/mcabber/configure.ac	Thu Apr 03 21:20:56 2008 +0200
@@ -67,6 +67,16 @@
 # Check for tm_gmtoff
 MC_TM_GMTOFF
 
+# Check if we must provide a SIGWINCH handler
+AC_ARG_ENABLE(sigwinch,
+        [  --enable-sigwinch       compile with SIGWINCH handler],
+        [with_sigwinch=$enableval],
+        [with_sigwinch=$with_ext_funcs])
+AC_MSG_RESULT($with_sigwinch)
+if test "$with_sigwinch" = yes; then
+    AC_DEFINE(USE_SIGWINCH, [], [Provide own SIGWINCH handler])
+fi
+
 # Checks for libraries.
 
 AC_CHECK_LIB(charset, locale_charset)