configure.in
changeset 131 f67d47083e3a
parent 128 a1f41ebde5c4
child 134 3df25ef89435
--- a/configure.in	Mon Mar 20 10:53:45 2006 +0000
+++ b/configure.in	Mon Mar 20 14:19:13 2006 +0000
@@ -13,7 +13,7 @@
 
 AM_PATH_GLIB_2_0
 
-LM_COMPILE_WARNINGS
+IDT_COMPILE_WARNINGS
 
 changequote(,)dnl
 if test "x$GCC" = "xyes"; then
@@ -39,6 +39,11 @@
 
 PKG_CHECK_MODULES(LOUDMOUTH, glib-2.0 >= $GLIB2_REQUIRED)
 
+# Check Unit test framework (defined in acinclude.m4)
+IDT_PATH_CHECK(0.9.2, have_check=yes, have_check=no)
+
+AM_CONDITIONAL(HAVE_CHECK, test x$have_check = xyes)
+
 dnl +--------------------+
 dnl | Check for gtk-doc. |-------------------------------
 dnl +--------------------+
@@ -185,6 +190,7 @@
 docs/reference/Makefile
 loudmouth/Makefile
 examples/Makefile
+tests/Makefile
 loudmouth-1.0.pc
 loudmouth.spec])
 
@@ -198,6 +204,7 @@
         compiler:                 ${CC}
         Enable SSL                ${enable_ssl}
         Enable Debug:             ${enable_debug}
+	Enable Unit Tests:        ${have_check}
 
         Now type 'make' to build Loudmouth
 "