CMakeLists.txt
changeset 95 f2f4c7810a72
parent 93 0a10228296c1
child 96 270ce1cfc823
--- a/CMakeLists.txt	Thu Mar 11 19:35:18 2010 +0200
+++ b/CMakeLists.txt	Sun Mar 14 22:10:17 2010 +0200
@@ -17,6 +17,7 @@
 
 cmake_minimum_required(VERSION 2.6)
 project(lua C)
+set(PROJECT_VERSION "0.0.1")
 
 ## User options
 option(DEBUG "Enable debugging output" ON)
@@ -61,7 +62,7 @@
 
 ## Packaging information
 set(CPACK_PACKAGE_NAME libmcabber-lua)
-set(CPACK_PACKAGE_VERSION "0.0.1")
+set(CPACK_PACKAGE_VERSION ${PROJECT_VERSION})
 set(CPACK_PACKAGE_VENDOR "IsBear")
 set(CPACK_PACKAGE_CONTACT "Myhailo Danylenko <isbear@ukrpost.net>")
 set(CPACK_PACKAGE_DESCRIPTION_SUMMARY "Mcabber lua module")