CMakeLists.txt
changeset 151 5d90caa7fb2c
parent 148 b222f4d111d9
child 153 8fba61f363a8
--- a/CMakeLists.txt	Sat Mar 05 18:36:28 2016 +0200
+++ b/CMakeLists.txt	Thu Mar 17 23:17:00 2016 +0200
@@ -16,13 +16,14 @@
 
 cmake_minimum_required(VERSION 2.6)
 project(lua C)
-set(PROJECT_VERSION "0.0.4")
+set(PROJECT_VERSION "0.0.5")
 
 ## User options
 option(DEBUG                 "Enable debugging output"                                                           ON)
 option(ENABLE_LUA_ALIAS      "Enable aliasing command '/lua' to corresponding '/lua5.x' at module loading time"  ON)
 option(LLM_CONNECTION_ENABLE "Enable exposing of mcabber loudmouth connection to lua"                            ON)
 option(LLM_LOG_HANDLER       "Enable registration of log messages handler for lua-loudmouth library's messages"  ON)
+option(COMPAT_0_0_4          "Provide global 'main' as alias to 'mcabber' for compatibility with v0.0.4"         ON)
 set(ML_SOURCE_PRIORITY G_PRIORITY_HIGH_IDLE CACHE STRING "Glib event source priority for timeout and bgread")
 set(ML_BGREAD_BUFFER   4096                 CACHE STRING "Background pipe reading buffer size")
 set(OPT_MLUA_RC        "lua_init_filename"  CACHE STRING "Mcabber option name to specify lua initialization file")