CMakeLists.txt
changeset 28 ff36ae7e2b1e
parent 27 0539bca09f11
child 30 060c59f6f3de
--- a/CMakeLists.txt	Thu Mar 04 19:50:56 2010 +0200
+++ b/CMakeLists.txt	Sun Mar 14 21:41:32 2010 +0200
@@ -16,6 +16,7 @@
 
 cmake_minimum_required(VERSION 2.6) 
 project(disco C) 
+set(PROJECT_VERSION "0.0.1")
 
 ## User settable options
  
@@ -49,7 +50,7 @@
 
 ## Packaging information
 set(CPACK_PACKAGE_NAME libmcabber-disco)
-set(CPACK_PACKAGE_VERSION "0.0.1")
+set(CPACK_PACKAGE_VERSION ${PROJECT_VERSION})
 set(CPACK_PACKAGE_VENDOR "IsBear")
 set(CPACK_PACKAGE_CONTACT "Myhailo Danylenko <isbear@ukrpost.net>")
 set(CPACK_PACKAGE_DESCRIPTION_SUMMARY "Mcabber module for service discovery requests")