CMakeLists.txt
changeset 40 fbdae6975352
parent 33 1cc77413e85d
--- a/CMakeLists.txt	Wed Aug 08 14:46:06 2012 +0300
+++ b/CMakeLists.txt	Mon Aug 20 20:37:24 2012 +0300
@@ -1,10 +1,10 @@
-## Copyright 2009 Myhailo Danylenko
-# This file is part of mcabber module writing howto examples.
+## Copyright 2009-2012 Myhailo Danylenko
+# This file is part of mcabber-avatar
 #
-# Examples are free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 2 of the License, or
-# (at your option) any later version.
+# mcabber-avatar is a free software: you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation, either version 2 of the
+# License, or (at your option) any later version.
 #
 # This program is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
@@ -26,9 +26,9 @@
 pkg_check_modules(LM REQUIRED loudmouth-1.0)
 pkg_check_modules(PNG REQUIRED libpng)
 pkg_check_modules(MCABBER REQUIRED mcabber)
-set(AALIB_LIBRARY_DIRS "/usr/lib" CACHE FILEPATH "Path, where AAlib is located")
-set(AALIB_INCLUDE_DIRS "/usr/include" CACHEĀ FILEPATH "Path to AAlib includes")
-set(AALIB_LIBRARIES "-laa" CACHE TEXT "Libraries, necessary to link with AAlib")
+set(AALIB_LIBRARY_DIRS "/usr/lib"     CACHE PATH   "Path, where AAlib is located")
+set(AALIB_INCLUDE_DIRS "/usr/include" CACHEĀ PATH   "Path to AAlib includes")
+set(AALIB_LIBRARIES    "-laa"         CACHE STRING "Libraries, necessary to link with AAlib")
 include(CheckIncludeFile)
 set(CMAKE_REQUIRED_INCLUDES ${MCABBER_INCLUDE_DIRS})
 check_include_file(mcabber/pep.h HAVE_MCABBER_PEP_H)
@@ -79,7 +79,7 @@
 if(DPKG_EXECUTABLE)
 	execute_process(COMMAND ${DPKG_EXECUTABLE} --print-architecture OUTPUT_VARIABLE CPACK_DEBIAN_PACKAGE_ARCHITECTURE OUTPUT_STRIP_TRAILING_WHITESPACE)
 else()
-	set(CPACK_DEBIAN_PACKAGE_ARCHITECTURE i386 CACHE TEXT "Architecture of package")
+	set(CPACK_DEBIAN_PACKAGE_ARCHITECTURE i386 CACHE STRING "Architecture of package")
 endif()
 set(CPACK_PACKAGE_FILE_NAME "${CPACK_PACKAGE_NAME}_${CPACK_PACKAGE_VERSION}_${CPACK_DEBIAN_PACKAGE_ARCHITECTURE}")
 set(CPACK_SOURCE_IGNORE_FILES "/\\\\..*;\\\\.swp;~$;/build/;\\\\.tar\\\\.;\\\\.deb;\\\\.so")
@@ -89,7 +89,7 @@
 
 ## Installation
 install(TARGETS avatar DESTINATION lib/mcabber) 
-install(FILES avatar.rc COPYING TODO README DESTINATION share/doc/${CPACK_PACKAGE_NAME})
+install(FILES docs/avatar.rc COPYING docs/todo.mdwn docs/readme.mdwn DESTINATION share/doc/${CPACK_PACKAGE_NAME})
 install(DIRECTORY help DESTINATION share/mcabber)
 install(FILES ${PROJECT_BINARY_DIR}/avatar.avv DESTINATION share/mcabber/avv/modules RENAME avatar)