CMakeLists.txt
changeset 23 2b7060ce1152
parent 22 4f45c246856c
child 24 7aa499342e2b
--- a/CMakeLists.txt	Mon Feb 22 23:25:24 2010 +0200
+++ b/CMakeLists.txt	Thu Mar 04 19:50:02 2010 +0200
@@ -22,7 +22,6 @@
 ## Check for build dependencies
 find_package(PkgConfig REQUIRED) 
 pkg_check_modules(GLIB REQUIRED glib-2.0) 
-pkg_check_modules(GMODULE REQUIRED gmodule-2.0) 
 pkg_check_modules(LM REQUIRED loudmouth-1.0)
 pkg_check_modules(PNG REQUIRED libpng)
 pkg_check_modules(MCABBER REQUIRED mcabber)
@@ -41,7 +40,6 @@
 set(CMAKE_REQUIRED_FLAGS ${LM_LDFLAGS} ${LM_CFLAGS})
 check_symbol_exists(lm_connection_unregister_reply_handler loudmouth/loudmouth.h HAVE_LM_CONNECTION_UNREGISTER_REPLY_HANDLER)
 link_directories(${GLIB_LIBRARY_DIRS}
-				 ${GMODULE_LIBRARY_DIRS}
 				 ${LM_LIBRARY_DIRS}
 				 ${PNG_LIBRARY_DIRS}
 				 ${AALIB_LIBRARY_DIRS}
@@ -53,13 +51,11 @@
 ## Compiler setup
 configure_file(config.h.in config.h)
 include_directories(SYSTEM ${GLIB_INCLUDE_DIRS} 
-                    ${GMODULE_INCLUDE_DIRS} 
                     ${LM_INCLUDE_DIRS}
 					${PNG_INCLUDE_DIRS}
 					${AALIB_INCLUDE_DIRS}
                     ${MCABBER_INCLUDE_DIRS})
 target_link_libraries(avatar ${GLIB_LIBRARIES}
-                      ${GMODULE_LIBRARIES}
 					  ${LM_LIBRARIES}
 					  ${PNG_LIBRARIES}
 					  ${AALIB_LIBRARIES}