Mon, 11 Apr 2016 00:17:17 +0100 chg: extract the logic of setting FD_CLOEXEC to a utility function
Jun Wu <quark@fb.com> [Mon, 11 Apr 2016 00:17:17 +0100] rev 28855
chg: extract the logic of setting FD_CLOEXEC to a utility function Setting FD_CLOEXEC is useful for other fds such like lockfd and sockdirfd, move the logic from hgc_open to util.
Sun, 10 Apr 2016 03:14:32 +0100 chg: add fchdirx as a utility function
Jun Wu <quark@fb.com> [Sun, 10 Apr 2016 03:14:32 +0100] rev 28854
chg: add fchdirx as a utility function As part of the series to support long socket paths, we need to use fchdir and check its result in several places. Make it a utility function.
Sun, 10 Apr 2016 22:58:11 +0100 chg: check lockfd at freecmdserveropts
Jun Wu <quark@fb.com> [Sun, 10 Apr 2016 22:58:11 +0100] rev 28853
chg: check lockfd at freecmdserveropts We check for sockdirfd at freecmdserveropts but not lockfd, which is a bit strange to people new to the code. Add a comment and an assert to make it clear that lockfd should be closed earlier.
Sun, 10 Apr 2016 23:56:00 +0100 chg: add sockdirfd to cmdserveropts
Jun Wu <quark@fb.com> [Sun, 10 Apr 2016 23:56:00 +0100] rev 28852
chg: add sockdirfd to cmdserveropts As part of the series to support long socket paths, we need to add the fd of the directory to the cmdserveropts structure so we can use basenames instead of full paths for sockname, redirectsockname, and lockfile.
Sun, 10 Apr 2016 21:56:05 +0100 chg: fix spelling in the error message about error waiting for cmdserver
Jun Wu <quark@fb.com> [Sun, 10 Apr 2016 21:56:05 +0100] rev 28851
chg: fix spelling in the error message about error waiting for cmdserver This is a trivial spelling and grammar fix.
Sun, 10 Apr 2016 11:02:58 -0700 sslutil: document and slightly refactor validation logic
Gregory Szorc <gregory.szorc@gmail.com> [Sun, 10 Apr 2016 11:02:58 -0700] rev 28850
sslutil: document and slightly refactor validation logic This main purpose of this patch is to make it clearer that fingerprint pinning takes precedence over CA verification. This will make subsequent refactoring to the validation code easier to read.
Sun, 10 Apr 2016 11:00:41 -0700 sslutil: require a server hostname when wrapping sockets (API)
Gregory Szorc <gregory.szorc@gmail.com> [Sun, 10 Apr 2016 11:00:41 -0700] rev 28849
sslutil: require a server hostname when wrapping sockets (API) All callers appear to be passing the hostname. So this shouldn't break anything. By specifying the hostname, more validation options from the ssl module are available to us. Although this patch stops short of using them.
Sun, 10 Apr 2016 10:59:45 -0700 sslutil: move and document verify_mode assignment
Gregory Szorc <gregory.szorc@gmail.com> [Sun, 10 Apr 2016 10:59:45 -0700] rev 28848
sslutil: move and document verify_mode assignment Consolidating all the SSLContext options setting makes the code a bit easier to read.
Sun, 10 Apr 2016 10:54:53 -0700 tests: use --insecure instead of web.cacerts=!
Gregory Szorc <gregory.szorc@gmail.com> [Sun, 10 Apr 2016 10:54:53 -0700] rev 28847
tests: use --insecure instead of web.cacerts=! --insecure is the proper and documented way to do this. The end result is the same: dispatch will set web.cacerts to ! when --insecure is passed. This patch is necessary to refactor handling of web.cacerts in upcoming patches.
Sun, 10 Apr 2016 10:58:47 -0700 help: remove references to "Python 2.6 or later"
Gregory Szorc <gregory.szorc@gmail.com> [Sun, 10 Apr 2016 10:58:47 -0700] rev 28846
help: remove references to "Python 2.6 or later" We require Python 2.6. So there is no value to these docs.
(0) -10000 -3000 -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 +10000 tip