Thu, 18 Dec 2014 12:07:03 -0600 subrepo: fix git subrepo ui argument
Matt Mackall <mpm@selenic.com> [Thu, 18 Dec 2014 12:07:03 -0600] rev 23580
subrepo: fix git subrepo ui argument
Sat, 13 Dec 2014 19:44:55 -0500 subrepo: drop the 'ui' parameter to revert()
Matt Harbison <matt_harbison@yahoo.com> [Sat, 13 Dec 2014 19:44:55 -0500] rev 23579
subrepo: drop the 'ui' parameter to revert() This no longer needs to be explicitly passed because the subrepo object tracks the 'ui' reference since fcbc66b5da6a. See the change to 'archive' for details about the differences between the output level in the root repo and subrepo 'ui' object. The only use for 'ui' in revert is to emit status and warning messages, and to check the verbose flag prior to printing the action to be performed on a file. The local repo's ui was already being used to print a warning message in wctx.forget() and for 'ui.slash' when walking dirstate in the repo.status() call. Unlike other methods where the matcher is passed along and narrowed, a new matcher is created in each repo, and therefore the bad() method already used the local repo's ui.
Sat, 13 Dec 2014 19:36:50 -0500 subrepo: drop the 'ui' parameter to removefiles()
Matt Harbison <matt_harbison@yahoo.com> [Sat, 13 Dec 2014 19:36:50 -0500] rev 23578
subrepo: drop the 'ui' parameter to removefiles() This no longer needs to be explicitly passed because the subrepo object tracks the 'ui' reference since fcbc66b5da6a. See the change to 'archive' for details about the differences between the output level in the root repo and subrepo 'ui' object. The only use for 'ui' in remove is to emit status and warning messages, and to check the verbose flag prior to printing files to be removed. The bad() method on the matcher still uses the root repo's ui, because narrowing the matcher doesn't change the ui object. The local repo's ui was already being used to print a warning message in wctx.forget() and for 'ui.slash' when walking dirstate in the repo.status() call.
Sat, 13 Dec 2014 19:23:30 -0500 subrepo: drop the 'ui' parameter to forget()
Matt Harbison <matt_harbison@yahoo.com> [Sat, 13 Dec 2014 19:23:30 -0500] rev 23577
subrepo: drop the 'ui' parameter to forget() This no longer needs to be explicitly passed because the subrepo object tracks the 'ui' reference since fcbc66b5da6a. See the change to 'archive' for details about the differences between the output level in the root repo and subrepo 'ui' object. The only use for 'ui' in forget is to emit status and warning messages, and to check the verbose flag prior to printing files to be forgotten. The bad() method on the matcher still uses the root repo's ui, because narrowing the matcher doesn't change the ui object. The local repo's ui was already being used to print a warning message in wctx.forget() and for 'ui.slash' when walking dirstate in the repo.status() call.
Sat, 13 Dec 2014 14:26:38 -0500 subrepo: drop the 'ui' parameter to cat()
Matt Harbison <matt_harbison@yahoo.com> [Sat, 13 Dec 2014 14:26:38 -0500] rev 23576
subrepo: drop the 'ui' parameter to cat() This no longer needs to be explicitly passed because the subrepo object tracks a 'ui' reference since fcbc66b5da6a. See the change to 'archive' for details about the differences between the output level in the root repo and subrepo 'ui' object. The only use for 'ui' in cat is to emit a status message when a subrepo is missing. The bad() method on the matcher still uses the root repo's ui, because narrowing the matcher doesn't change the ui object.
Sat, 13 Dec 2014 14:53:46 -0500 subrepo: drop the 'ui' parameter to archive()
Matt Harbison <matt_harbison@yahoo.com> [Sat, 13 Dec 2014 14:53:46 -0500] rev 23575
subrepo: drop the 'ui' parameter to archive() The current state of subrepo methods is to pass a 'ui' object to some methods, which has the effect of overriding the subrepo configuration since it is the root repo's 'ui' that is passed along as deep as there are subrepos. Other subrepo method are *not* passed the root 'ui', and instead delegate to their repo object's 'ui'. Even in the former case where the root 'ui' is available, some methods are inconsistent in their use of both the root 'ui' and the local repo's 'ui'. (Consider hg._incoming() uses the root 'ui' for path expansion and some status messages, but also calls bundlerepo.getremotechanges(), which eventually calls discovery.findcommonincoming(), which calls setdiscovery.findcommonheads(), which calls status() on the local repo 'ui'.) This inconsistency with respect to the configured output level is probably always hidden, because --verbose, --debug and --quiet, along with their 'ui.xxx' equivalents in the global and user level hgrc files are propagated from the parent repo to the subrepo via 'baseui'. The 'ui.xxx' settings in the parent repo hgrc file are not propagated, but that seems like an unusual thing to set on a per repo config file. Any 'ui.xxx' options changed by --config are also not propagated, because they are set on repo.ui by dispatch.py, not repo.baseui. The goal here is to cleanup the subrepo methods by dropping the 'ui' parameter, which in turn prevents mixing subtly different 'ui' instances on a given subrepo level. Some methods use more than just the output level settings in 'ui' (add for example ends up calling scmutil.checkportabilityalert() with both the root and local repo's 'ui' at different points). This series just goes for the low hanging fruit and switches methods that only use the output level. If we really care about not letting a subrepo config override the root repo's output level, we can propagate the verbose, debug and quiet settings to the subrepo in the same way 'ui.commitsubrepos' is in hgsubrepo.__init__. Archive only uses the 'ui' object to call its progress() method, and gitsubrepo calls status().
Sat, 13 Dec 2014 22:44:22 -0500 subrepo: use 'self.ui' instead of 'self._repo.ui'
Matt Harbison <matt_harbison@yahoo.com> [Sat, 13 Dec 2014 22:44:22 -0500] rev 23574
subrepo: use 'self.ui' instead of 'self._repo.ui' They are now equivalent, but the former is slightly more readable.
Sat, 13 Dec 2014 20:43:01 -0500 subrepo: reset 'self.ui' to the subrepo copy of 'ui' in the hgsubrepo class
Matt Harbison <matt_harbison@yahoo.com> [Sat, 13 Dec 2014 20:43:01 -0500] rev 23573
subrepo: reset 'self.ui' to the subrepo copy of 'ui' in the hgsubrepo class Creation of the subrepo's '_repo' object creates a new 'ui' by combining the parent repo's 'baseui' and reading in the subrepo's hgrc file. This simply avoids 'self.ui' and 'self._repo.ui' pointing to different objects, which seems like a potential source of bugs. Git and Svn subrepos are unchanged, because they don't have their own ui, and have always used their parent's for their configuration.
Sat, 13 Dec 2014 15:19:38 -0500 subrepo: rename the '_ui' member to 'ui'
Matt Harbison <matt_harbison@yahoo.com> [Sat, 13 Dec 2014 15:19:38 -0500] rev 23572
subrepo: rename the '_ui' member to 'ui' The localrepository class has a 'ui' member, so keeping the names the same will allow for duck typing with subrepo instances when accessing 'ui'. Changing this is easier than finding all of the localrepository instance uses and renaming that to '_ui'.
Sat, 13 Dec 2014 15:13:07 -0500 subrepo: drop the '_ui' member in the subrepo subclasses
Matt Harbison <matt_harbison@yahoo.com> [Sat, 13 Dec 2014 15:13:07 -0500] rev 23571
subrepo: drop the '_ui' member in the subrepo subclasses This member has existed in the base class since fcbc66b5da6a.
Tue, 09 Dec 2014 09:35:04 -0500 graphmod: attempt to clarify documentation of groupbranchiter()
Augie Fackler <raf@durin42.com> [Tue, 09 Dec 2014 09:35:04 -0500] rev 23570
graphmod: attempt to clarify documentation of groupbranchiter() Thanks to Pierre-Yves for checking my cleanups here and helping me understand the algorithm well enough to help document it.
Mon, 08 Dec 2014 15:20:28 -0500 graphmod: rename graph-topological config to graph-group-branches
Augie Fackler <raf@durin42.com> [Mon, 08 Dec 2014 15:20:28 -0500] rev 23569
graphmod: rename graph-topological config to graph-group-branches The latter suggests what the change is slightly better.
Thu, 04 Sep 2014 19:28:17 +0200 groupbranchiter: allow callers to select the first branch
Pierre-Yves David <pierre-yves.david@fb.com> [Thu, 04 Sep 2014 19:28:17 +0200] rev 23568
groupbranchiter: allow callers to select the first branch Instead of just bootstrapping the algorithm with the first revision we see, allow callers to pass revs that should be displayed first. All branches are retained until we can display such revision. Expected usage is to display the current working copy parent first.
Thu, 04 Sep 2014 19:05:36 +0200 groupbranchiter: support for non-contiguous revsets
Pierre-Yves David <pierre-yves.david@fb.com> [Thu, 04 Sep 2014 19:05:36 +0200] rev 23567
groupbranchiter: support for non-contiguous revsets The algorithm now works when some revisions are skipped. We now use "first included ancestors" instead of just "parent" to link changesets with each other.
Fri, 14 Nov 2014 20:08:59 +0000 groubranchhiter: indent most of the inner code
Pierre-Yves David <pierre-yves.david@fb.com> [Fri, 14 Nov 2014 20:08:59 +0000] rev 23566
groubranchhiter: indent most of the inner code We are going to add an additional layer of indentation to support non-contiguous revset. We do it in a pure code movement changeset to help the readability of the next changeset.
Fri, 14 Nov 2014 17:37:59 +0000 graphlog: add a way to test the 'groupbranchiter' function
Pierre-Yves David <pierre-yves.david@fb.com> [Fri, 14 Nov 2014 17:37:59 +0000] rev 23565
graphlog: add a way to test the 'groupbranchiter' function We add an experimental config option to use the topological sorting. I first tried to hook the 'groupbranchiter' function in the 'sort' revset but this was useless because graphlog enforces revision number sorting :( As the goal is to advance on the topological iteration logic, I see this experimental option as a good way to move forward. We have to use turn the iterator into a list because the graphlog is apparently not ready for pure iterator input yet.
Thu, 04 Sep 2014 18:19:32 +0200 graphmod: add a function for topological iteration
Pierre-Yves David <pierre-yves.david@fb.com> [Thu, 04 Sep 2014 18:19:32 +0200] rev 23564
graphmod: add a function for topological iteration This changeset introduces a function to perform topological (one branch after the other) iteration over a set of changesets. This first version has a lot of limitations, but the approach should be flexible enough to allow many improvements in the future. This changeset aims to set the first stone more than providing a complete solution. The algorithm does not need to know the whole set of nodes involved before emitting revision. This makes it a good candidate for usage in place like `hg log` or graphical tools that need a fast first result time.
Fri, 17 Oct 2014 15:27:12 -0700 namespaces: add branches
Sean Farley <sean.michael.farley@gmail.com> [Fri, 17 Oct 2014 15:27:12 -0700] rev 23563
namespaces: add branches Note that the exception-catching from the previous branchtip check is moved up to catch exceptions from the try block surrounding the namespace lookup.
Fri, 17 Oct 2014 15:27:33 -0700 namespaces: add tags
Sean Farley <sean.michael.farley@gmail.com> [Fri, 17 Oct 2014 15:27:33 -0700] rev 23562
namespaces: add tags
Sun, 14 Dec 2014 19:11:44 -0800 namespaces: remove weakref; always pass in repo
Ryan McElroy <rmcelroy@fb.com> [Sun, 14 Dec 2014 19:11:44 -0800] rev 23561
namespaces: remove weakref; always pass in repo It turns out that maintaining a reference of any sort (even weak!) to the repo when constructed doesn't work because we may at some point pass in a repoview filtered by something other than what the initial repo was.
Thu, 16 Oct 2014 23:27:54 -0700 changectx: use names api to simplify and extend node lookup
Sean Farley <sean.michael.farley@gmail.com> [Thu, 16 Oct 2014 23:27:54 -0700] rev 23560
changectx: use names api to simplify and extend node lookup Previously, changectx had to know about each type of name (bookmark, tag, etc.) to look up. Now, we use repo.namenodes to simplify (and extend) this.
Fri, 17 Oct 2014 15:28:40 -0700 namespaces: add a method to the first matching node for a given name
Sean Farley <sean.michael.farley@gmail.com> [Fri, 17 Oct 2014 15:28:40 -0700] rev 23559
namespaces: add a method to the first matching node for a given name
Sun, 14 Dec 2014 12:53:50 -0800 namespaces: add bookmarks to the names data structure
Sean Farley <sean.michael.farley@gmail.com> [Sun, 14 Dec 2014 12:53:50 -0800] rev 23558
namespaces: add bookmarks to the names data structure This marks the first use of abstracting our different types of named objects (bookmarks, tags, branches, etc.) and upcoming patches will use this to simplify logic.
Sun, 14 Dec 2014 16:22:24 -0800 namespaces: add a convenience property for the weakref _repo
Sean Farley <sean.michael.farley@gmail.com> [Sun, 14 Dec 2014 16:22:24 -0800] rev 23557
namespaces: add a convenience property for the weakref _repo
Sun, 14 Dec 2014 15:35:57 -0800 namespaces: pass repo to __init__
Sean Farley <sean.michael.farley@gmail.com> [Sun, 14 Dec 2014 15:35:57 -0800] rev 23556
namespaces: pass repo to __init__ We store repo as a weakref so that we can prevent a cycle between namespaces and localrepo.
Sun, 14 Dec 2014 15:04:40 -0800 namespaces: add a function to turn single results into lists
Sean Farley <sean.michael.farley@gmail.com> [Sun, 14 Dec 2014 15:04:40 -0800] rev 23555
namespaces: add a function to turn single results into lists
Fri, 17 Oct 2014 11:25:51 -0700 namespaces: add a method to register new namespaces
Sean Farley <sean.michael.farley@gmail.com> [Fri, 17 Oct 2014 11:25:51 -0700] rev 23554
namespaces: add a method to register new namespaces
Sun, 14 Dec 2014 12:29:28 -0800 namespaces: introduce a generic way to map between names and nodes
Sean Farley <sean.michael.farley@gmail.com> [Sun, 14 Dec 2014 12:29:28 -0800] rev 23553
namespaces: introduce a generic way to map between names and nodes This patch begins the work to provide a way to register a namespace to handle 'names'. Benefits of this would be, - improved templating: This would provide {name} which could output any branch, bookmark, tag, or any extension registered namespace all without having the extension doing any extra work - improved tab completion: Since this provides a single source of all 'names', tab completion would not need to know of each namespace - changeset lookup: Similar to before, a unified place to get all 'names' will allow finding changesets without any extension code having to reimplement this Also, d226fe36e362 has shown us that for internal code which expects a certain type of method or behavior, we should provide an easy way for extensions to check this behavior.
Sun, 14 Dec 2014 19:27:58 +0100 statichttprepo: update profile of __call__ in mock vfs object
Mads Kiilerich <madski@unity3d.com> [Sun, 14 Dec 2014 19:27:58 +0100] rev 23552
statichttprepo: update profile of __call__ in mock vfs object New code paths could fail because the old statichttprepo profile couldn't handle the usual parameters. Instead, reuse a more generic profile also used in readonlyvfs.
Sun, 14 Dec 2014 21:00:58 +0100 tests: avoid git diffstat singular/plural output difference
Mathias De Maré <mathias.demare@gmail.com> [Sun, 14 Dec 2014 21:00:58 +0100] rev 23551
tests: avoid git diffstat singular/plural output difference 'git diff --stat' output changed with regard to the amount of changes/insertions/deletions shown. In older git versions (1.7.7.6), output was shown as: 2 files changed, 2 insertions(+), 1 deletions(-) In newer versions, output is shown as: 2 files changed, 2 insertions(+), 1 deletion(-) This patch uses a regex to handle both cases.
(0) -10000 -3000 -1000 -300 -100 -50 -30 +30 +50 +100 +300 +1000 +3000 +10000 tip