Thu, 28 Jun 2018 23:36:45 +0530 rebase: add lock to cover whole dryrun process
Sushil khanchi <sushilkhanchi97@gmail.com> [Thu, 28 Jun 2018 23:36:45 +0530] rev 38495
rebase: add lock to cover whole dryrun process Before this patch it is easy for another hg to interrupt the dryrun. This patch make sure that dryrun will complete without any interruption. Differential Revision: https://phab.mercurial-scm.org/D3854
Tue, 29 May 2018 00:26:20 +0200 merge: add a 'keepconflictparent' argument to graft
Boris Feld <boris.feld@octobus.net> [Tue, 29 May 2018 00:26:20 +0200] rev 38494
merge: add a 'keepconflictparent' argument to graft Before this change, `merge.graft` was always dropping the "grafted" changeset from the parent. This is impractical in case of conflict as the second parent can be useful to help with conflict resolution. We add a new boolean parameter to control this behavior. This will make using `merge.graft` directly in shelve practicable. Differential Revision: https://phab.mercurial-scm.org/D3692
Thu, 28 Jun 2018 18:07:22 -0700 unlinkpath: make empty directory removal optional (issue5901) (issue5826)
Kyle Lippincott <spectral@google.com> [Thu, 28 Jun 2018 18:07:22 -0700] rev 38493
unlinkpath: make empty directory removal optional (issue5901) (issue5826) There are known cases where performing operations such as rebase from a directory that is newly created can fail or at least lead to being in a directory handle that no longer exists. This is even reproducible by just doing something as simple as: cd foo; hg rm * The behavior is different if you use `hg addremove`, the directory is not removed until we attempt to go back to the node after committing it: cd foo; rm *; hg addremove; hg ci -m'bye foo'; hg co .^; hg co tip Differential Revision: https://phab.mercurial-scm.org/D3859
Thu, 28 Jun 2018 21:24:47 +0530 py3: convert opts keys to bytes using pycompat.byteskwargs()
Pulkit Goyal <7895pulkit@gmail.com> [Thu, 28 Jun 2018 21:24:47 +0530] rev 38492
py3: convert opts keys to bytes using pycompat.byteskwargs() This fixes the py3 build broken due to 56b2074114b19e12abd9cd4c378d58b702232705. Differential Revision: https://phab.mercurial-scm.org/D3853
Thu, 28 Jun 2018 22:23:08 -0400 procutil: add a shim for translating shell commands to native commands
Matt Harbison <matt_harbison@yahoo.com> [Thu, 28 Jun 2018 22:23:08 -0400] rev 38491
procutil: add a shim for translating shell commands to native commands
Sat, 16 Jun 2018 23:26:40 +0900 revset: move lookup of first ancestor() candidate out of the loop
Yuya Nishihara <yuya@tcha.org> [Sat, 16 Jun 2018 23:26:40 +0900] rev 38490
revset: move lookup of first ancestor() candidate out of the loop
Sat, 16 Jun 2018 23:21:47 +0900 revset: leverage orset() to flatten ancestor() arguments
Yuya Nishihara <yuya@tcha.org> [Sat, 16 Jun 2018 23:21:47 +0900] rev 38489
revset: leverage orset() to flatten ancestor() arguments This also makes orset() accept an empty argument because nullary ancestor() call is valid. That's not the case for orset(), but should be okay.
Sat, 16 Jun 2018 23:12:41 +0900 revset: remove orphan i18n comment from ancestor()
Yuya Nishihara <yuya@tcha.org> [Sat, 16 Jun 2018 23:12:41 +0900] rev 38488
revset: remove orphan i18n comment from ancestor()
Thu, 28 Jun 2018 23:21:55 +0530 grep: deprecates `--all` flag
Sangeet Kumar Mishra <mail2sangeetmishra@gmail.com> [Thu, 28 Jun 2018 23:21:55 +0530] rev 38487
grep: deprecates `--all` flag As the name "all" is a misnomer for an option that searches on diffs of revisions, we are moving to diff flag from all, deprecating it in the process. Differential Revision: https://phab.mercurial-scm.org/D3825
Tue, 26 Jun 2018 10:02:01 -0700 namespaces: let namespaces override singlenode() definition
Martin von Zweigbergk <martinvonz@google.com> [Tue, 26 Jun 2018 10:02:01 -0700] rev 38486
namespaces: let namespaces override singlenode() definition Some namespaces have multiple nodes per name (meaning that their namemap() returns multiple nodes). One such namespace is the "topics" namespace (from the evolve repo). We also have our own internal namespace at Google (for review units) that has multiple nodes per name. These namespaces may not want to use the default "pick highest revnum" resolution that we currently use when resolving a name to a single node. As an example, they may decide that `hg co <name>` should check out a commit that's last in some sense even if an earlier commit had just been amended and thus had a higher revnum [1]. This patch gives the namespace the option to continue to return multiple nodes and to override how the best node is picked. Allowing namespaces to override that may also be useful as an optimization (it may be cheaper for the namespace to find just that node). I have been arguing (in D3715) for using all the nodes returned from namemap() when resolving the symbol to a revset, so e.g. `hg log -r stable` would resolve to *all* nodes on stable, not just the one with the highest revnum (except that I don't actually think we should change it for the branch namespace because of BC). Most people seem opposed to that. If we decide not to do it, I think we can deprecate the namemap() function in favor of the new singlenode() (I find it weird to have namespaces, like the branch namespace, where namemap() isn't nodemap()'s inverse). I therefore think this patch makes sense regardless of what we decide on that issue. [1] Actually, even the branch namespace would have wanted to override singlenode() if it had supported multiple nodes. That's because closes branch heads are mostly ignored, so "hg co default" will not check out the highest-revnum node if that's a closed head. Differential Revision: https://phab.mercurial-scm.org/D3852
(0) -30000 -10000 -3000 -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 +10000 tip