Wed, 27 May 2015 13:22:48 -0700 match: don't remove '.' from _includeroots
Martin von Zweigbergk <martinvonz@google.com> [Wed, 27 May 2015 13:22:48 -0700] rev 25579
match: don't remove '.' from _includeroots This makes _includeroots more like _fileroots and gives visitdir() a nice symmetry in the two. I'm hoping to later combine the two (_fileroots and _includeroots), and having them treated similarly should make that step easier to follow.
Sun, 31 May 2015 13:17:41 -0700 match: join two nested if-blocks
Martin von Zweigbergk <martinvonz@google.com> [Sun, 31 May 2015 13:17:41 -0700] rev 25578
match: join two nested if-blocks Instead of if a: if b: return False let's write it if a and b: return False
Wed, 27 May 2015 11:47:55 -0700 match: drop optimization (?) of 'parentdirs' calculation
Martin von Zweigbergk <martinvonz@google.com> [Wed, 27 May 2015 11:47:55 -0700] rev 25577
match: drop optimization (?) of 'parentdirs' calculation It seems unlikely that the optimization to avoid calling util.finddirs twice will be noticeable, so let's drop it. This makes the two conditions for includes and regular patterns more similar.
Wed, 27 May 2015 09:34:00 -0700 match: break boolean expressions into one operand per line
Martin von Zweigbergk <martinvonz@google.com> [Wed, 27 May 2015 09:34:00 -0700] rev 25576
match: break boolean expressions into one operand per line This makes it much easier to spot both the operators ('and'/'or') and the operands.
Wed, 27 May 2015 13:23:35 -0700 match: drop unnecessary removal of '.' from excluded roots
Martin von Zweigbergk <martinvonz@google.com> [Wed, 27 May 2015 13:23:35 -0700] rev 25575
match: drop unnecessary removal of '.' from excluded roots The repo root is nothing special when it comes to what directories to visit: patterns like '-X relglob:*.py' should not exclude the top directory, while '-X path:.' should (pointless as such a pattern may be). The explicit removal of '.' from the set of excluded roots was probably there to avoid removing the the root directory when any patterns had been given, but since 20ad936ac5d2 (treemanifest: visit directory 'foo' when given e.g. '-X foo/ba?', 2015-05-27), we only exclude directories that should be completely excluded, so we no longer need to special-case the root directory.
Fri, 12 Jun 2015 11:00:50 -0700 changegroup: simplify by not reusing 'prog(ress)' instance
Martin von Zweigbergk <martinvonz@google.com> [Fri, 12 Jun 2015 11:00:50 -0700] rev 25574
changegroup: simplify by not reusing 'prog(ress)' instance Just create a new instance of the 'prog' class for each step instead of replacing its fields and resetting the counter.
Fri, 12 Jun 2015 10:54:10 -0700 changegroup: don't use 'repo' for non-repo 'self'
Martin von Zweigbergk <martinvonz@google.com> [Fri, 12 Jun 2015 10:54:10 -0700] rev 25573
changegroup: don't use 'repo' for non-repo 'self' 'repo' is a very confusing name to use for 'self', especially when it's not a repo. Also drop repo.ui member (a.k.a. self.ui) now that 'self' doesn't shadow outer 'repo' variable.
Sun, 14 Jun 2015 21:51:57 -0400 subrepo: introduce hgsubrepo._getctx()
Matt Harbison <matt_harbison@yahoo.com> [Sun, 14 Jun 2015 21:51:57 -0400] rev 25572
subrepo: introduce hgsubrepo._getctx() This code is already used in a couple of places, and will need to be used in others where wdir() support is needed. Trying to get the wdir() revision stored in self._substate[1] when creating the object in subrepo.subrepo() resulted in breaking various status and diff tests. This is a far less invasive change.
Sun, 14 Jun 2015 13:08:11 -0400 convert: apply the appropriate phases to the destination (issue4165)
Matt Harbison <matt_harbison@yahoo.com> [Sun, 14 Jun 2015 13:08:11 -0400] rev 25571
convert: apply the appropriate phases to the destination (issue4165) If the conversion doesn't change the hash, and the cset is public in the source, it should be public in the destination. (This can happen if file remapping is done that doesn't affect the initial commits.) This also propagates the secret phase from the source, regardless of the hash, because presumably the content is what is secret. Otherwise, the destination commit stays in the draft phase. Maybe any draft cset with an unchanged hash should be changed to public, because it has effectively been shared, but convert pretty strongly implies throwing away (or at least readonly archiving) the source repo. The change in the rollback output is because the name of the outer transaction is now 'convert', which seems more accurate. Unfortunately, the memctx won't indicate the hash prior to committing, so the proper phase can't be applied with the commit. The repo is already write locked in mercurial_sink.before().
Sun, 14 Jun 2015 13:04:00 -0400 convert: always track the hg source revision in the internal commit object
Matt Harbison <matt_harbison@yahoo.com> [Sun, 14 Jun 2015 13:04:00 -0400] rev 25570
convert: always track the hg source revision in the internal commit object This will be needed in the next patch to determine if phases need to be adjusted. The insertion of the source revision in 'extras{}' is still controlled by the config property.
(0) -10000 -3000 -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 +10000 tip