Sun, 17 Oct 2010 04:13:50 +0200 test-https: test web.cacerts functionality
Mads Kiilerich <mads@kiilerich.com> [Sun, 17 Oct 2010 04:13:50 +0200] rev 12741
test-https: test web.cacerts functionality
Sun, 17 Oct 2010 04:13:35 +0200 serve: fix https mode and add test
Mads Kiilerich <mads@kiilerich.com> [Sun, 17 Oct 2010 04:13:35 +0200] rev 12740
serve: fix https mode and add test The https mode failed in super because BaseRequestHandler is an old-style class. This introduces the first test of https client/server functionality - and "hghave ssl". The test is currently only run on Python 2.6.
Sat, 16 Oct 2010 17:29:04 -0500 hgweb: don't send a body or illegal headers during 304 response
Augie Fackler <durin42@gmail.com> [Sat, 16 Oct 2010 17:29:04 -0500] rev 12739
hgweb: don't send a body or illegal headers during 304 response Without this fix, mod_wsgi and spawning get in a wedged state after sending a 304 response. Not sending a body fixed that problem. The header change was discovered by using wsgiref.validate.validator to check for other errors.
Sat, 16 Oct 2010 22:40:46 +0200 merge with stable
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sat, 16 Oct 2010 22:40:46 +0200] rev 12738
merge with stable
Tue, 12 Oct 2010 11:02:45 -0500 test-url: skip test when ssl module is unavailable stable
Augie Fackler <durin42@gmail.com> [Tue, 12 Oct 2010 11:02:45 -0500] rev 12737
test-url: skip test when ssl module is unavailable
Sat, 16 Oct 2010 18:50:53 +0200 revset: use 'requires' instead of 'wants' in error message
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sat, 16 Oct 2010 18:50:53 +0200] rev 12736
revset: use 'requires' instead of 'wants' in error message
Fri, 15 Oct 2010 05:21:51 +0200 outgoing: unify common graphlog.outgoing and hg.outgoing code
Nicolas Dumazet <nicdumz.commits@gmail.com> [Fri, 15 Oct 2010 05:21:51 +0200] rev 12735
outgoing: unify common graphlog.outgoing and hg.outgoing code
Thu, 14 Oct 2010 22:41:43 +0200 bundlerepo: unify common code into a new getremotechanges
Nicolas Dumazet <nicdumz.commits@gmail.com> [Thu, 14 Oct 2010 22:41:43 +0200] rev 12734
bundlerepo: unify common code into a new getremotechanges The pattern where we fetch incoming remote changes and return them as a local bundlerepo seems common. It's nicer to have this code unified.
Tue, 12 Oct 2010 23:33:43 -0500 revset id(): fix error text to say "id wants..." instead of "rev wants..."
Augie Fackler <durin42@gmail.com> [Tue, 12 Oct 2010 23:33:43 -0500] rev 12733
revset id(): fix error text to say "id wants..." instead of "rev wants..."
Thu, 14 Oct 2010 22:53:17 +0200 keyword: only use expensive fctx.cmp when needed
Christian Ebert <blacktrash@gmx.net> [Thu, 14 Oct 2010 22:53:17 +0200] rev 12732
keyword: only use expensive fctx.cmp when needed Restrict expensive cmp to cases when: - comparing against working directory and - encode filters active or - path is configured for keyword expansion
Thu, 14 Oct 2010 22:47:50 +0200 context: narrow down filter special case in filectx.cmp()
Christian Ebert <blacktrash@gmx.net> [Thu, 14 Oct 2010 22:47:50 +0200] rev 12731
context: narrow down filter special case in filectx.cmp() cmp via filelog when encode filters are present, but only when actually comparing to the working directory.
Thu, 14 Oct 2010 21:36:00 +0200 incoming: unify code for incoming and graphlog.incoming
Nicolas Dumazet <nicdumz.commits@gmail.com> [Thu, 14 Oct 2010 21:36:00 +0200] rev 12730
incoming: unify code for incoming and graphlog.incoming
Thu, 14 Oct 2010 21:37:00 +0200 incoming: rename variable
Nicolas Dumazet <nicdumz.commits@gmail.com> [Thu, 14 Oct 2010 21:37:00 +0200] rev 12729
incoming: rename variable Groundwork so that incoming and graphlog.incoming code look the same and get easier to unify.
Thu, 14 Oct 2010 01:28:29 +0200 import: only the first hg patch marker should be processed (issue2417)
Mads Kiilerich <mads@kiilerich.com> [Thu, 14 Oct 2010 01:28:29 +0200] rev 12728
import: only the first hg patch marker should be processed (issue2417) Proper use of the hgpatch state variable had been lost in the final edits of d7452292f9d3 - now it works more like intended.
Fri, 10 Sep 2010 10:28:18 +0200 backout: provide linear backout as a default (without --merge option)
Gilles Moris <gilles.moris@free.fr> [Fri, 10 Sep 2010 10:28:18 +0200] rev 12727
backout: provide linear backout as a default (without --merge option) This changes backouts changeset to retain linear history, .e. it is committed as a child of the working directory parent, not the reverted changeset parent. The default behavior was previously to just commit a reverted change as a child of the backed out changeset - thus creating a new head. Most of the time, you would use the --merge option, as it does not make sense to keep this dangling head as is. The previous behavior could be obtained by using 'hg update --clean .' after a 'hg backout --merge'. The --merge option itself is not affected by this change. There is also still an autocommit of the backout if a merge is not needed, i.e. in case the backout is the parent of the working directory. Previously we had (pwd = parent of the working directory): pwd older backout auto merge backout --merge auto commit With the new linear approach: pwd older backout auto commit backout --merge auto commit auto: commit done by the backout command merge: backout also already committed but explicit merge and commit needed commit: user need to commit the update/merge
Mon, 11 Oct 2010 10:07:42 -0500 update: use revsingle to enable use of revsets as update targets (issue1993)
Augie Fackler <durin42@gmail.com> [Mon, 11 Oct 2010 10:07:42 -0500] rev 12726
update: use revsingle to enable use of revsets as update targets (issue1993)
Tue, 12 Oct 2010 11:02:45 -0500 test-url: skip test when ssl module is unavailable
Augie Fackler <durin42@gmail.com> [Tue, 12 Oct 2010 11:02:45 -0500] rev 12725
test-url: skip test when ssl module is unavailable
Tue, 12 Oct 2010 11:02:05 -0500 test-url: remove trailing whitespace
Augie Fackler <durin42@gmail.com> [Tue, 12 Oct 2010 11:02:05 -0500] rev 12724
test-url: remove trailing whitespace
Tue, 12 Oct 2010 12:49:23 +0100 keyword: code cleanup
Christian Ebert <blacktrash@gmx.net> [Tue, 12 Oct 2010 12:49:23 +0100] rev 12723
keyword: code cleanup - move preselection of expansion candidates for rollback and record into helper function - same overwrite order in rollback and record: 1. modified, 2. added - self.wlock() inside kwrepo class instead of repo.wlock()
Sat, 02 Oct 2010 22:59:29 +0900 tests: asciify output of test-encoding-align.t
Yuya Nishihara <yuya@tcha.org> [Sat, 02 Oct 2010 22:59:29 +0900] rev 12722
tests: asciify output of test-encoding-align.t
Sat, 02 Oct 2010 22:57:25 +0900 tests: accept \-escaped test output
Yuya Nishihara <yuya@tcha.org> [Sat, 02 Oct 2010 22:57:25 +0900] rev 12721
tests: accept \-escaped test output It changes tsttest to accept expected outputs in python-style \-escapes. It aims to avoid trouble with outputs for non-ascii, color and progress tests.
Tue, 12 Oct 2010 16:26:03 -0500 merge with crew
Matt Mackall <mpm@selenic.com> [Tue, 12 Oct 2010 16:26:03 -0500] rev 12720
merge with crew
Tue, 12 Oct 2010 08:30:15 -0500 parentdelta: compress.py extension is no longer necessary
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Tue, 12 Oct 2010 08:30:15 -0500] rev 12719
parentdelta: compress.py extension is no longer necessary Using `hg --config format.parentdelta=True clone --pull src dst` is equivalent.
Tue, 12 Oct 2010 16:25:38 -0500 merge with stable
Matt Mackall <mpm@selenic.com> [Tue, 12 Oct 2010 16:25:38 -0500] rev 12718
merge with stable
Fri, 01 Oct 2010 10:15:04 -0500 convert/darcs: support changelogs with bytes 0x7F-0xFF (issue2411) stable
Brodie Rao <brodie@bitheap.org> [Fri, 01 Oct 2010 10:15:04 -0500] rev 12717
convert/darcs: support changelogs with bytes 0x7F-0xFF (issue2411) This is a followup to 4481f8a93c7a, which only fixed the conversion of patches with UTF-8 metadata. This patch allows a changelog to have any bytes with values 0x7F-0xFF. It parses the XML changelog as Latin-1 and uses converter_source.recode() to decode the data as UTF-8/Latin-1. Caveats: - Since the convert extension doesn't provide any way to specify the source encoding, users are still limited to UTF-8 and Latin-1. - etree will still complain if the changelog has bytes with values 0x00-0x19. XML only allows printable characters.
Mon, 11 Oct 2010 09:44:19 -0500 revset: add id() and rev() to allow explicitly referring to changes by hash or rev
Augie Fackler <durin42@gmail.com> [Mon, 11 Oct 2010 09:44:19 -0500] rev 12716
revset: add id() and rev() to allow explicitly referring to changes by hash or rev
Sun, 10 Oct 2010 12:41:36 -0500 revset: rename tagged() to tag() and allow it to take an optional tag name
Augie Fackler <durin42@gmail.com> [Sun, 10 Oct 2010 12:41:36 -0500] rev 12715
revset: rename tagged() to tag() and allow it to take an optional tag name
Sun, 10 Oct 2010 12:40:25 -0500 bookmarks: add revset for referencing bookmarks
Augie Fackler <durin42@gmail.com> [Sun, 10 Oct 2010 12:40:25 -0500] rev 12714
bookmarks: add revset for referencing bookmarks
Sun, 10 Oct 2010 12:03:28 -0500 hgweb help: fix double help links
Augie Fackler <durin42@gmail.com> [Sun, 10 Oct 2010 12:03:28 -0500] rev 12713
hgweb help: fix double help links
Mon, 11 Oct 2010 11:17:48 +0200 tests: add testcase for --config format.dotencode=false
Adrian Buehlmann <adrian@cadifra.com> [Mon, 11 Oct 2010 11:17:48 +0200] rev 12712
tests: add testcase for --config format.dotencode=false
(0) -10000 -3000 -1000 -300 -100 -50 -30 +30 +50 +100 +300 +1000 +3000 +10000 +30000 tip