Wed, 22 Apr 2015 12:33:08 -0700 localrepo: eliminate local requirements var in init
Drew Gottlieb <drgott@google.com> [Wed, 22 Apr 2015 12:33:08 -0700] rev 24918
localrepo: eliminate local requirements var in init Localrepo's __init__ function creates a local requirements set to add to before it replaces the instance's set with it. This is unnecessary, so let's just use the instance's set directly.
Wed, 22 Apr 2015 12:16:19 -0700 localrepo: rename requirements parameter in stream_in()
Drew Gottlieb <drgott@google.com> [Wed, 22 Apr 2015 12:16:19 -0700] rev 24917
localrepo: rename requirements parameter in stream_in() To avoid confusion from overloading of the variable name "requirements", the requirements is renamed to remotereqs for localrepo's stream_in() function.
Wed, 22 Apr 2015 12:59:12 -0700 localrepo: have stream_in() not modify its argument
Drew Gottlieb <drgott@google.com> [Wed, 22 Apr 2015 12:59:12 -0700] rev 24916
localrepo: have stream_in() not modify its argument Localrepo's stream_in function modified its requirements argument. This is not good practice because it may be unexpected behavior to the caller.
Wed, 22 Apr 2015 12:06:44 -0700 localrepo: make _applyrequirements more specific
Drew Gottlieb <drgott@google.com> [Wed, 22 Apr 2015 12:06:44 -0700] rev 24915
localrepo: make _applyrequirements more specific Localrepo's _applyrequirements function isn't very straightforward about what it does. Its purpose is to both act as a setter for the requirements attribute, and to apply appropriate requirements to the opener's configuration. This change makes the function just focus on the latter responsibility. We rename it as such, and make setting the requirements attribute the responsibility of the caller.
Tue, 21 Apr 2015 17:16:10 -0700 localrepo: make requirements always be a set in localrepo.__init__
Drew Gottlieb <drgott@google.com> [Tue, 21 Apr 2015 17:16:10 -0700] rev 24914
localrepo: make requirements always be a set in localrepo.__init__ The init function used to create a local list, and then convert it to a set before assigning it as a data attribute. This change simplifies the function by having it always be a set, requiring no conversion.
Tue, 21 Apr 2015 16:55:30 -0700 localrepo: eliminate requirements class variable (API)
Drew Gottlieb <drgott@google.com> [Tue, 21 Apr 2015 16:55:30 -0700] rev 24913
localrepo: eliminate requirements class variable (API) Localrepo's requirements class variable was introduced in b090601a80d1 to make requirements modifiable by extensions. A main access point, _baserequirements, still exists, but this change undoes making the class variable to begin with. Without this simplification, there is a class variable with a default value that is only copied, but never directly used. This behavior is moved directly into the _baserequirements function.
Wed, 29 Apr 2015 10:30:58 -0700 changegroup.group: drop 'reorder' parameter
Martin von Zweigbergk <martinvonz@google.com> [Wed, 29 Apr 2015 10:30:58 -0700] rev 24912
changegroup.group: drop 'reorder' parameter Since we always pass self._reorder to self.group(), let's drop the parameter and let group() read from self._reorder itself. There are no other in-tree callers to group().
Wed, 29 Apr 2015 10:38:45 -0700 cg2packer: set reorder=False in __init__ instead of in group()
Martin von Zweigbergk <martinvonz@google.com> [Wed, 29 Apr 2015 10:38:45 -0700] rev 24911
cg2packer: set reorder=False in __init__ instead of in group() The difference between reorder=None (bundle.reorder=auto) and reorder=False is that the generaldelta revlogs get reordered with the former. In cg2packer, group() we check if the revlog uses generaldelta and if reorder=None and then convert that to reorder=False. We are effectively saying that whether or not generaldelta is used, we want reorder=None to mean reorder=False for changegroup 2. To make this clearer, check if reorder=None in the constructor and change it to False there and drop the overriding of group(). Also document the reason for turning reordering off.
Thu, 23 Apr 2015 09:44:22 -0700 changegroup: use 'reorder is None' instead of 'reorder is not True/False'
Martin von Zweigbergk <martinvonz@google.com> [Thu, 23 Apr 2015 09:44:22 -0700] rev 24910
changegroup: use 'reorder is None' instead of 'reorder is not True/False' The config option bundle.reorder can be {on,off,auto}, which gets read into the 'reorder' variable as {True,False,None}. In two places, we need to decide how to handle the None/auto case. I personally find it easier to read those expressions when written to explicitly compare to None.
Thu, 09 Apr 2015 23:47:07 -0400 crecord: fix mixed imports warning
Matt Harbison <matt_harbison@yahoo.com> [Thu, 09 Apr 2015 23:47:07 -0400] rev 24909
crecord: fix mixed imports warning
(0) -10000 -3000 -1000 -300 -100 -10 +10 +100 +300 +1000 +3000 +10000 tip