mercurial/__main__.py
author Pierre-Yves David <pierre-yves.david@octobus.net>
Wed, 06 Mar 2024 01:53:52 +0100
changeset 51526 a03fa40afd01
parent 50697 e7ef11b75fdc
permissions -rw-r--r--
filteredhash: rename the filteredhash function The new name is less ambiguous, as we are about to introduce an alternative function it seems like a good idea to have clearer name to distinct the two.

def run():
    from . import demandimport

    with demandimport.tracing.log('hg script'):
        demandimport.enable()
        from . import dispatch

        dispatch.run()


if __name__ == '__main__':
    run()