tests/test-issue5979.t
author Pierre-Yves David <pierre-yves.david@octobus.net>
Fri, 05 Apr 2024 14:11:02 +0200
changeset 51583 22cc679a7312
parent 40369 ef6cab7930b3
permissions -rw-r--r--
phases: move RemotePhasesSummary to revision number This continue our quest to align more logic on revision number instead of node-ids. The motivation is similar to the change to `new_heads` and `analyze_remote_phases` a few changeset earlier. Again, we take this as an opportunity to rename the class, and the attribute to the new naming scheme. This will highlight the need for code update for any code using it an expecting node-ids. Many of the rev-num → node-id conversion we had to introduce in the previous changesets can now be removed. More will be removed in the future as we continue to align code toward rev-num usage. time saved in the 100 milliseconds order of magnitude for the mozilla-try benchmark I have been using.

  $ hg init r1
  $ cd r1
  $ hg ci --config ui.allowemptycommit=true -m c0
  $ hg ci --config ui.allowemptycommit=true -m c1
  $ hg ci --config ui.allowemptycommit=true -m c2
  $ hg co -q 0
  $ hg ci --config ui.allowemptycommit=true -m c3
  created new head
  $ hg co -q 3
  $ hg merge --quiet
  $ hg ci --config ui.allowemptycommit=true -m c4

  $ hg log -G -T'{desc}'
  @    c4
  |\
  | o  c3
  | |
  o |  c2
  | |
  o |  c1
  |/
  o  c0
  

  >>> from mercurial import hg
  >>> from mercurial import ui as uimod
  >>> repo = hg.repository(uimod.ui())
  >>> for anc in repo.changelog.ancestors([4], inclusive=True):
  ...   print(anc)
  4
  3
  2
  1
  0