setup.py
branchstable
changeset 21839 f266be73f764
parent 21229 54d7657d7d1e
child 21840 0c88185c7d6c
--- a/setup.py	Tue Jul 01 23:32:18 2014 -0500
+++ b/setup.py	Sat Jul 05 07:31:08 2014 -0700
@@ -534,7 +534,7 @@
     # so Mercurial can continue to compile in the meantime.
     if xcode51:
         cflags = get_config_var('CFLAGS')
-        if re.search(r'-mno-fused-madd\b', cflags) is not None:
+        if cflags and re.search(r'-mno-fused-madd\b', cflags) is not None:
             os.environ['CFLAGS'] = (
                 os.environ.get('CFLAGS', '') + ' -Qunused-arguments')