setup.py
changeset 5623 f22708f50213
parent 5396 5105b119edd2
child 6009 f077815932ce
--- a/setup.py	Fri Dec 07 18:14:16 2007 -0600
+++ b/setup.py	Fri Dec 07 18:15:24 2007 -0600
@@ -40,6 +40,11 @@
 except ImportError:
     pass
 
+if os.name in ['nt']:
+    extra['scripts'] = ['hg']
+else:
+    extra['scripts'] = ['hg', 'hgmerge']
+
 # specify version string, otherwise 'hg identify' will be used:
 version = ''
 
@@ -78,7 +83,6 @@
                    [os.path.join(root, file_) for file_ in files])
                   for root, dirs, files in os.walk('templates')],
       cmdclass=cmdclass,
-      scripts=['hg', 'hgmerge'],
       options=dict(py2exe=dict(packages=['hgext']),
                    bdist_mpkg=dict(zipdist=True,
                                    license='COPYING',