setup.py
changeset 15500 d5abe76da61e
parent 15494 7a7a1c594daf
child 15523 f9da84a950d0
--- a/setup.py	Sun Aug 21 15:23:43 2011 +0200
+++ b/setup.py	Sat Nov 12 02:08:01 2011 +0100
@@ -78,7 +78,8 @@
             raise SystemExit("--c2to3 is only compatible with python3.")
         raise
     sys.path.append('contrib')
-
+elif sys.version_info[0] >= 3:
+    raise SystemExit("setup.py with python3 needs --c2to3 (experimental)")
 
 scripts = ['hg']
 if os.name == 'nt':