setup.py
changeset 16688 cfb6682961b8
parent 16683 525fdb738975
child 16689 f366d4c2ff34
--- a/setup.py	Sat May 12 16:00:58 2012 +0200
+++ b/setup.py	Sat May 12 16:02:45 2012 +0200
@@ -23,16 +23,16 @@
 try:
     import hashlib
     sha = hashlib.sha1()
-except:
+except ImportError:
     try:
         import sha
-    except:
+    except ImportError:
         raise SystemExit(
             "Couldn't import standard hashlib (incomplete Python install).")
 
 try:
     import zlib
-except:
+except ImportError:
     raise SystemExit(
         "Couldn't import standard zlib (incomplete Python install).")
 
@@ -41,7 +41,7 @@
 try:
     isironpython = (platform.python_implementation()
                     .lower().find("ironpython") != -1)
-except:
+except AttributeError:
     pass
 
 if isironpython:
@@ -49,7 +49,7 @@
 else:
     try:
         import bz2
-    except:
+    except ImportError:
         raise SystemExit(
             "Couldn't import standard bz2 (incomplete Python install).")