setup.py
changeset 46369 cabc5e9366c5
parent 46315 2ef575c62f10
child 46414 16c18d5e5dc8
--- a/setup.py	Mon Jan 18 10:24:20 2021 +0100
+++ b/setup.py	Fri Jan 22 11:10:39 2021 +0100
@@ -609,6 +609,12 @@
         # and its build is not explictely disabled (for external build
         # as Linux distributions would do)
         if self.distribution.rust and self.rust:
+            if not sys.platform.startswith('linux'):
+                self.warn(
+                    "rust extensions have only been tested on Linux "
+                    "and may not behave correctly on other platforms"
+                )
+
             for rustext in ruststandalones:
                 rustext.build('' if self.inplace else self.build_lib)