setup.py
changeset 2311 b832b6eb65ab
parent 1977 7eb694a1c1af
child 2324 7cbe8cd69d6b
--- a/setup.py	Thu May 18 10:09:16 2006 -0700
+++ b/setup.py	Thu May 18 11:48:33 2006 -0700
@@ -57,6 +57,8 @@
             self.includes += mercurial.packagescan.getmodules(self.build_lib,
                                                               'mercurial')
             self.includes += mercurial.packagescan.getmodules(self.build_lib,
+                                                              'mercurial/hgweb')
+            self.includes += mercurial.packagescan.getmodules(self.build_lib,
                                                               'hgext')
             build_exe.finalize_options(self)
 except ImportError:
@@ -85,7 +87,7 @@
         url='http://selenic.com/mercurial',
         description='Scalable distributed SCM',
         license='GNU GPL',
-        packages=['mercurial', 'hgext'],
+        packages=['mercurial', 'mercurial.hgweb', 'hgext'],
         ext_modules=[Extension('mercurial.mpatch', ['mercurial/mpatch.c']),
                     Extension('mercurial.bdiff', ['mercurial/bdiff.c'])],
         data_files=[('mercurial/templates',