setup.py
branchstable
changeset 40446 b6bc2293cdf3
parent 40397 36b134c436b8
child 40495 3a333a582d7b
--- a/setup.py	Wed Oct 31 12:08:37 2018 -0700
+++ b/setup.py	Wed Oct 31 20:32:42 2018 +0100
@@ -168,6 +168,9 @@
 from distutils.sysconfig import get_python_inc, get_config_var
 from distutils.version import StrictVersion
 
+# Explain to distutils.StrictVersion how our release candidates are versionned
+StrictVersion.version_re = re.compile(r'^(\d+)\.(\d+)(\.(\d+))?-?(rc(\d+))?$')
+
 def write_if_changed(path, content):
     """Write content to a file iff the content hasn't changed."""
     if os.path.exists(path):