setup.py
changeset 39572 b6b9488aae4c
parent 39329 729082bb9938
child 39608 ec68135a8935
--- a/setup.py	Fri Sep 07 10:18:20 2018 -0700
+++ b/setup.py	Wed Sep 05 01:18:29 2018 +0530
@@ -11,6 +11,9 @@
     # Mercurial will never work on Python 3 before 3.5 due to a lack
     # of % formatting on bytestrings, and can't work on 3.6.0 or 3.6.1
     # due to a bug in % formatting in bytestrings.
+    # We cannot support Python 3.5.0, 3.5.1, 3.5.2 because of bug in
+    # codecs.escape_encode() where it raises SystemError on empty bytestring
+    # bug link: https://bugs.python.org/issue25270
     #
     # TODO: when we actually work on Python 3, use this string as the
     # actual supportedpy string.
@@ -21,6 +24,9 @@
         '!=3.2.*',
         '!=3.3.*',
         '!=3.4.*',
+        '!=3.5.0',
+        '!=3.5.1',
+        '!=3.5.2',
         '!=3.6.0',
         '!=3.6.1',
     ])