setup.py
branchstable
changeset 15367 b357a972d6cd
parent 15215 c41078b9d0b8
child 15388 eb6c0d47c3d5
--- a/setup.py	Tue Oct 25 08:56:59 2011 -0400
+++ b/setup.py	Wed Oct 26 12:56:27 2011 -0500
@@ -133,14 +133,14 @@
 
 version = ''
 
+env = {'HGRCPATH': '', 'LANGUAGE': 'C'}
+
 if os.path.isdir('.hg'):
     # Execute hg out of this directory with a custom environment which
     # includes the pure Python modules in mercurial/pure. We also take
     # care to not use any hgrc files and do no localization.
     pypath = ['mercurial', os.path.join('mercurial', 'pure')]
-    env = {'PYTHONPATH': os.pathsep.join(pypath),
-           'HGRCPATH': '',
-           'LANGUAGE': 'C'}
+    env['PYTHONPATH'] = os.pathsep.join(pypath)
     if 'LD_LIBRARY_PATH' in os.environ:
         env['LD_LIBRARY_PATH'] = os.environ['LD_LIBRARY_PATH']
     if 'SystemRoot' in os.environ: