setup.py
branchstable
changeset 50733 b1ac55606eb7
parent 50643 cbcbf63b6dbf
child 50761 2c34c9b61a4f
child 50930 5dc7e1907e48
--- a/setup.py	Thu Mar 23 16:45:12 2023 +0100
+++ b/setup.py	Tue Jun 27 12:09:17 2023 +0200
@@ -112,7 +112,10 @@
 if issetuptools:
     from setuptools import setup
 else:
-    from distutils.core import setup
+    try:
+        from distutils.core import setup
+    except ModuleNotFoundError:
+        from setuptools import setup
 from distutils.ccompiler import new_compiler
 from distutils.core import Command, Extension
 from distutils.dist import Distribution