setup.py
branchstable
changeset 33589 a0bfcd08f5fe
parent 33588 025017423e53
child 33591 ee11d18fcd3c
--- a/setup.py	Fri Jul 21 10:46:31 2017 -0400
+++ b/setup.py	Wed Jul 26 23:39:42 2017 +0900
@@ -576,7 +576,7 @@
         # Screen out egg related commands to prevent egg generation.  But allow
         # mercurial.egg-info generation, since that is part of modern
         # packaging.
-        excl = {'bdist_egg'}
+        excl = set(['bdist_egg'])
         return filter(lambda x: x not in excl, install.get_sub_commands(self))
 
 class hginstalllib(install_lib):