setup.py
changeset 44452 9d2b2df2c2ba
parent 44440 d543ef183eb8
child 44466 79ac59d3f73d
--- a/setup.py	Fri Mar 06 10:52:44 2020 +0100
+++ b/setup.py	Fri Mar 06 13:27:41 2020 -0500
@@ -935,11 +935,11 @@
             normalizecrlf('doc/%s.html' % root)
 
         # This logic is duplicated in doc/Makefile.
-        sources = set(
+        sources = {
             f
             for f in os.listdir('mercurial/helptext')
             if re.search(r'[0-9]\.txt$', f)
-        )
+        }
 
         # common.txt is a one-off.
         gentxt('common')
@@ -979,7 +979,7 @@
         # Screen out egg related commands to prevent egg generation.  But allow
         # mercurial.egg-info generation, since that is part of modern
         # packaging.
-        excl = set(['bdist_egg'])
+        excl = {'bdist_egg'}
         return filter(lambda x: x not in excl, install.get_sub_commands(self))