setup.py
changeset 12501 98f21e4d9633
parent 11533 5be8760d2fb3
child 12649 6c0e1aee1b19
--- a/setup.py	Sat Sep 25 19:47:45 2010 -0500
+++ b/setup.py	Sun Sep 26 21:37:42 2010 +0200
@@ -229,7 +229,7 @@
         try:
             build_ext.build_extension(self, ext)
         except CCompilerError:
-            if not hasattr(ext, 'optional') or not ext.optional:
+            if not getattr(ext, 'optional', False):
                 raise
             log.warn("Failed to build optional extension '%s' (skipping)",
                      ext.name)