rust/hg-cpython/Cargo.toml
changeset 43289 8d432d3a2d7c
parent 43214 649a9601b9e2
child 44231 25ed4d8e707f
--- a/rust/hg-cpython/Cargo.toml	Sat Oct 05 10:21:34 2019 -0400
+++ b/rust/hg-cpython/Cargo.toml	Mon Oct 14 16:15:19 2019 +0900
@@ -11,9 +11,14 @@
 [features]
 default = ["python27"]
 
+# Features to build an extension module:
 python27 = ["cpython/python27-sys", "cpython/extension-module-2-7"]
+python3 = ["cpython/python3-sys", "cpython/extension-module"]
 
-python3 = ["cpython/python3-sys", "cpython/extension-module"]
+# Enable one of these features to build a test executable linked to libpython:
+# e.g. cargo test --no-default-features --features python27-bin
+python27-bin = ["cpython/python27-sys"]
+python3-bin = ["cpython/python3-sys"]
 
 [dependencies]
 hg-core = { path = "../hg-core" }