setup.py
changeset 6513 66e87c11447d
parent 6389 0231f763ebc8
child 6792 b2c4be19d7b1
--- a/setup.py	Thu Apr 10 14:25:50 2008 +0200
+++ b/setup.py	Thu Apr 10 23:07:54 2008 +0200
@@ -19,6 +19,9 @@
 import mercurial.version
 
 extra = {}
+scripts = ['hg']
+if os.name == 'nt':
+    scripts.append('contrib/win32/hg.bat')
 
 # simplified version of distutils.ccompiler.CCompiler.has_function
 # that actually removes its temporary files.
@@ -119,7 +122,7 @@
       url='http://selenic.com/mercurial',
       description='Scalable distributed SCM',
       license='GNU GPL',
-      scripts=['hg'],
+      scripts=scripts,
       packages=packages,
       ext_modules=ext_modules,
       data_files=[(os.path.join('mercurial', root),