setup.py
changeset 48833 64a8cdf4f327
parent 48832 b07b034cf548
child 48836 e020dbbc41e5
--- a/setup.py	Wed Mar 02 10:13:45 2022 -0500
+++ b/setup.py	Wed Mar 02 10:14:24 2022 -0500
@@ -1243,13 +1243,6 @@
     'hgdemandimport',
 ]
 
-# The pygit2 dependency dropped py2 support with the 1.0 release in Dec 2019.
-# Prior releases do not build at all on Windows, because Visual Studio 2008
-# doesn't understand C 11.  Older Linux releases are buggy.
-if sys.version_info[0] == 2:
-    packages.remove('hgext.git')
-
-
 for name in os.listdir(os.path.join('mercurial', 'templates')):
     if name != '__pycache__' and os.path.isdir(
         os.path.join('mercurial', 'templates', name)