rust/rhg/Cargo.toml
changeset 50174 596a6b9b0570
parent 49913 c15b415d1bff
child 50326 3f31b8526d66
--- a/rust/rhg/Cargo.toml	Wed Feb 22 18:10:26 2023 +0100
+++ b/rust/rhg/Cargo.toml	Wed Feb 22 18:42:09 2023 +0100
@@ -5,21 +5,21 @@
     "Antoine Cezar <antoine.cezar@octobus.net>",
     "Raphaël Gomès <raphael.gomes@octobus.net>",
 ]
-edition = "2018"
+edition = "2021"
 
 [dependencies]
 atty = "0.2.14"
 hg-core = { path = "../hg-core"}
-chrono = "0.4.19"
-clap = "2.34.0"
+chrono = "0.4.23"
+clap = { version = "4.0.24", features = ["cargo"] }
 derive_more = "0.99.17"
-home = "0.5.3"
+home = "0.5.4"
 lazy_static = "1.4.0"
-log = "0.4.14"
-micro-timer = "0.4.0"
-regex = "1.5.5"
-env_logger = "0.9.0"
+log = "0.4.17"
+logging_timer = "1.1.0"
+regex = "1.7.0"
+env_logger = "0.9.3"
 format-bytes = "0.3.0"
 users = "0.11.0"
-which = "4.2.5"
+which = "4.3.0"
 rayon = "1.6.1"