setup.py
changeset 42075 456c37433c43
parent 42074 59b1bdf85b1a
child 42172 71d8b4d91616
--- a/setup.py	Thu Apr 04 15:40:48 2019 +0200
+++ b/setup.py	Fri Apr 05 18:36:43 2019 -0400
@@ -583,9 +583,9 @@
         if err or returncode != 0:
             raise DistutilsExecError(err)
 
-        with open(self._indexfilename, 'w') as f:
-            f.write('# this file is autogenerated by setup.py\n')
-            f.write('docs = ')
+        with open(self._indexfilename, 'wb') as f:
+            f.write(b'# this file is autogenerated by setup.py\n')
+            f.write(b'docs = ')
             f.write(out)
 
 class buildhgexe(build_ext):