setup.py
changeset 27220 4374d819ccd5
parent 27127 7309853eedae
child 27222 511a4384b033
--- a/setup.py	Thu Dec 03 10:56:05 2015 -0500
+++ b/setup.py	Thu Dec 03 21:37:01 2015 -0800
@@ -177,11 +177,9 @@
 
 version = ''
 
-# Execute hg out of this directory with a custom environment which
-# includes the pure Python modules in mercurial/pure. We also take
-# care to not use any hgrc files and do no localization.
-pypath = ['mercurial', os.path.join('mercurial', 'pure')]
-env = {'PYTHONPATH': os.pathsep.join(pypath),
+# Execute hg out of this directory with a custom environment which takes care
+# to not use any hgrc files and do no localization.
+env = {'HGMODULEPOLICY': 'py',
        'HGRCPATH': '',
        'LANGUAGE': 'C'}
 if 'LD_LIBRARY_PATH' in os.environ: