setup.py
changeset 31562 3db113eef95f
parent 31561 312e62640798
child 31596 ab51a2b18f87
--- a/setup.py	Mon Mar 20 15:11:18 2017 -0700
+++ b/setup.py	Mon Mar 20 15:43:27 2017 -0700
@@ -595,6 +595,16 @@
     if re.search(plat, sys.platform) and hasfunction(new_compiler(), func):
         osutil_cflags.append('-DHAVE_%s' % func.upper())
 
+for plat, header in [
+    ('bsd|darwin|linux', 'sys/mount.h'),
+    ('bsd|darwin|linux', 'sys/param.h'),
+    ('linux', 'linux/magic.h'),
+    ('linux', 'sys/vfs.h'),
+]:
+    if re.search(plat, sys.platform) and hasheader(new_compiler(), header):
+        macro = header.replace('/', '_').replace('.', '_').upper()
+        osutil_cflags.append('-DHAVE_%s' % macro)
+
 if sys.platform == 'darwin':
     osutil_ldflags += ['-framework', 'ApplicationServices']