setup.py
changeset 9129 395b0e132836
parent 9124 632df73485ae
child 9142 63cfacb7917e
--- a/setup.py	Fri Jul 10 13:40:25 2009 +0200
+++ b/setup.py	Tue Jul 14 22:42:05 2009 -0400
@@ -248,6 +248,8 @@
 datafiles = []
 for root in ('templates', 'i18n'):
     for dir, dirs, files in os.walk(root):
+        dirs[:] = [x for x in dirs if not x.startswith('.')]
+        files = [x for x in files if not x.startswith('.')]
         datafiles.append((os.path.join('mercurial', dir),
                           [os.path.join(dir, file_) for file_ in files]))